Spigot 1.8 Dependency wont install

Discussion in 'Spigot Plugin Help' started by RacO.o, May 14, 2022.

  1. I'm running a server on 1.8 and need extra particles for a game we are making. So we decided to use https://github.com/ByteZ1337/ParticleLib but when trying to install it im having problems with the maven shading of the plugin, any help would be appreciated. This is my pom rn.
     

    Attached Files:

  2. you don't shade librarlies like that. you define it as normal dependency. just unlike with spigota-pi dependency you do NOT add <scope>provided</scope> to particlelib
     
    #2 Janmm14, May 14, 2022
    Last edited: May 14, 2022
  3. Yeah I changed it after a while to this but it's still not working.
     

    Attached Files:

    • pom.txt
      File size:
      4.9 KB
      Views:
      4