Spigot & BungeeCord 1.15.2

Discussion in 'News and Announcements' started by md_5, Jan 21, 2020.

    • Funny Funny x 1
  1. Code (Text):

    [15:26:28] [Server thread/INFO]: Starting Minecraft server on *:25565
    [15:26:28] [Server thread/INFO]: Using default channel type
    [15:26:29] [Server thread/WARN]: Initializing Legacy Material Support. Unless you have legacy plugins and/or data this is a bug!
     
    Is the `Initializing Legacy Material Support.` a new thing? It started showing up with 1.15.2, I don't know why it says that. It's on both Paper 1.15.2 and Spigot 1.15.2. even on first start, without even a plugins/ folder.

    Since I don't have legacy plugins if I fresh start without anything .. does that mean it's suddenly a bug?
     
  2. I get the same message, but only if I have a plugin that doesn't specify "api-version" in the plugin.yml

    Code (Text):
    [16:09:00] [Server thread/WARN]: Initializing Legacy Material Support. Unless you have legacy plugins and/or data this is a bug!
    [16:09:03] [Server thread/WARN]: Legacy plugin HungerKeeperPlus v1.4.1 does not specify an api-version.
    [16:09:04] [Server thread/WARN]: Legacy plugin dynmap v3.0-beta-10-257 does not specify an api-version.
     
  3. md_5

    Administrator Developer

    Cannot reproduce
     
  4. Probably your current world
     
  5. Shows on existing world too now with spigot 1.15.2, but if i put a clean spigot 1.15.2 that i make with buildtools into a new dir with no world and let it generate, it starts, and says that..

    i can defn. reproduce this.
     
  6. md_5

    Administrator Developer

    @ShaneBee tested in another thread and also couldn't reproduce. Are you up to date?
    Post the full log
     
  7. it's just .. get buildtools make new spigot jar, start it, accept eula, give it a port in server properties and let it generate a world.

    the log is literally just spigot starting and loading the world etc to done. no plugins, new world, i used seed: ilujf
    but it's showing on old world that we upgraded throughout the years, but in 1.15.1 it didn't say it.

    says the same with downloading latest paper , so i dunno.. could it be a java11 thing?

    [edit: thought i pasted the link] https://hasteb.in/leyodihe.md
     
  8. md_5

    Administrator Developer

  9. md_5

    Administrator Developer

    o.b.c.legacy.CraftLegacy, but unless you are also having the issue there probably isn't any easy debugging you can do.

    If you are just print a stack trace and see what's loading it
     
  10. md_5

    Administrator Developer

    @mrfloris if you update and run with debug=true in server.properties you should get a stack trace
     
  11. My mom got sick and at her age she needs additional help. I really wish I could work on this now, but I need to refocus, sorry. Maybe by Sunday or if I have time tonight.
     
    • Friendly Friendly x 2
  12. Has anybody noticed in 1.15.2 that when players reconnect to a work where they had a bee nest or hive in their inventory it says once:

    [04:56:37] [Server thread/WARN]: Unable to resolve BlockEntity for ItemStack: minecraft:beehive
    [04:56:37] [Server thread/WARN]: Unable to resolve BlockEntity for ItemStack: minecraft:bee_nest

    ?
     
  13. I logged in, gave myself a bee's nest and a beehive, logged out, logged back in, and no errors.
     
  14. Yeah, but you freshly gave yourself these.
    These were in the player inventory from 1.15.1, in world a, they teleported to world b, logged out, came back in 1.15.2 in world b, and teleported to world a, and then this msg comes up.

    it's just once though.
     
  15. /timings report doesn't work!!!!
     
  16. Did a plugin switch their inventories around when they switched worlds?
     
  17. Yes, for one person at least, they went between skyblock and normal gameplay and the other ppl went from mining world and normal world (they share the same inventory, just not the skyblock one)