Spigot & BungeeCord 1.16.1

Discussion in 'News and Announcements' started by md_5, Jun 25, 2020.

Thread Status:
Not open for further replies.
  1. Definitely an online server- for many years - that's why the missing UUID so noticeable - but had recent access problems - thanks for your comments - we will double check our - default server settings for each server on bungeecord.
     
    #241 DaDMaR777, Jul 4, 2020
    Last edited: Jul 5, 2020
  2. upload_2020-7-4_22-46-2.png
    Without any errors I've updated all our games apart from one...... this one.....
    The --forceUpgrade on the 1.15.2 is fine, as soon as I launch the 1.16.1 I get this....

    Any help is welcomed!
     
  3. Please note that when I made a test upgrade of one of my servers, several configuration files were replaced by a 1.16.1 version as can be seen by the dates on the picture below.
    upload_2020-7-4_23-10-51.png
    Many of these dated 04/07/2020 were previously dated 11/05/2020
    There is no apparent reason why they should have been replaced.

    I haven't checked them yet, but these changes could cause issues.

    I also noted that on another server where the 'world' used a custom name, the default 'world' files were generated!
     
  4. [INFO]
    [INFO] --- maven-jar-plugin:3.2.0:jar (default-jar) @ spigot-api ---
    [INFO] Building jar: /home/dadmar777/server/Midgard/Spigot/Spigot-API/target/spigot-api-1.16.1-R0.1-SNAPSHOT.jar
    [INFO]
    [INFO] --- maven-shade-plugin:3.2.3:shade (default) @ spigot-api ---
    [INFO] Including commons-lang:commons-lang:jar:2.6 in the shaded jar.
    [INFO] Including com.google.guava:guava:jar:21.0 in the shaded jar.
    [INFO] Including com.google.code.gson:gson:jar:2.8.0 in the shaded jar.
    [INFO] Including net.md-5:bungeecord-chat:jar:1.16-R0.1 in the shaded jar.
    [INFO] Including org.yaml:snakeyaml:jar:1.26 in the shaded jar.
    [INFO] Attaching shaded artifact.
    [INFO]
    [INFO] --- maven-install-plugin:2.4:install (default-install) @ spigot-api ---
    [INFO] Installing /home/dadmar777/server/Midgard/Spigot/Spigot-API/target/spigot-api-1.16.1-R0.1-SNAPSHOT.jar to /home/dadmar777/.m2/repository/org/spigotmc/spigot-api/1.16.1-R0.1-SNAPSHOT/spigot-api-1.16.1-R0.1-SNAPSHOT.jar
    [INFO] Installing /home/dadmar777/server/Midgard/Spigot/Spigot-API/pom.xml to /home/dadmar777/.m2/repository/org/spigotmc/spigot-api/1.16.1-R0.1-SNAPSHOT/spigot-api-1.16.1-R0.1-SNAPSHOT.pom
    [INFO] ------------------------------------------------------------------------
    [INFO] Reactor Summary:
    [INFO]
    [INFO] Spigot-API 1.16.1-R0.1-SNAPSHOT .................... FAILURE [ 13.637 s]
    [INFO] Spigot-Parent dev-SNAPSHOT ......................... SKIPPED
    [INFO] Spigot 1.16.1-R0.1-SNAPSHOT ........................ SKIPPED
    [INFO] ------------------------------------------------------------------------
    [INFO] BUILD FAILURE
    [INFO] ------------------------------------------------------------------------
    [INFO] Total time: 13.751 s
    [INFO] Finished at: 2020-07-05T15:32:57+10:00
    [INFO] ------------------------------------------------------------------------
    [ERROR] Failed to execute goal org.apache.maven.plugins:maven-install-plugin:2.4:install (default-install) on project spigot-api: Failed to install metadata org.spigotmc:spigot-api:1.16.1-R0.1-SNAPSHOT/maven-metadata.xml: Could not parse metadata /home/dadmar777/.m2/repository/org/spigotmc/spigot-api/1.16.1-R0.1-SNAPSHOT/maven-metadata-local.xml: in epilog non whitespace content is not allowed but got n (position: END_TAG seen ...</metadata>\nn... @21:2) -> [Help 1]
    [ERROR]
    [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
    [ERROR] Re-run Maven using the -X switch to enable full debug logging.
    [ERROR]
    [ERROR] For more information about the errors and possible solutions, please read the following articles:
    [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
    Error compiling Spigot. Please check the wiki for FAQs.
    If this does not resolve your issue then please pastebin the entire BuildTools.log.txt file when seeking support.
    Spigot-API 1.16.1-R0.1-SNAPSHOT .................... FAILURE [ 13.637 s]
    Should I pastebin the entire BuildTools.log.txt as an error ??
     
  5. md_5

    Administrator Developer

    /home/dadmar777/.m2/repository/org/spigotmc/spigot-api/1.16.1-R0.1-SNAPSHOT/

    Delete this folder, idk what happened
     
    • Winner Winner x 1
  6. Running Linux MINT 19.3
    LOL that
    /home/dadmar777/.m2/repository/org/spigotmc/spigot-api/
    folder is full of snapshot folders

    1.12.2-RO.1-SNAPSHOT
    1.3.2- " "
    1.14.1- " "

    etc all the way to the current one

    1.16.1-R0.1-SNAPSHOT

    Total of 10 past folders ?

    https://pastebin.com/u2QHzYGe
    Hope this helps
     
    #246 DaDMaR777, Jul 5, 2020
    Last edited: Jul 5, 2020
  7. That folder contains Maven build data which Spigot uses. Somehow a file in the 1.16.1-R0.1-SNAPSHOT got corrupted. Simply delete the entire folder and re-run BuildTools and it will (properly) regenerate the necessary files. The other versions can be left untouched.
     
    • Like Like x 1
    • Winner Winner x 1
  8. It's unfortunate that the team still has to defend their position after nearly a decade of existence and countless hours of amazing work. People these days are becoming increasingly demanding, increasingly unintelligent in programming knowledge, and have the audacity to make urgent demands towards a completely free product.

    Shame on them, they poorly reflect the community. Keep up the good work, as always.
     
    • Agree Agree x 3
    • Like Like x 1
  9. It seems there is an endcity-gateway issue in 1.16: it only uses one seed to generate one 'list' that is used for generating those gateways...
    So, if you have one end world.. let's call it 'world1' and have 19 gateways by killing 19 dragons in that world... and on the other hand you have another end world 'world2' : there is only ONE gateway #20 for that world left to generate...
    I'm not sure if this is a mojang issue, or Spigot...
    In my plugin i already used a 'fix' for this issue...

    Just wanted to know if this maybe is an spigot 'bug' ???

    Anyways: keep up the good work!!!
     
  10. Yes, we know, and noted/checked/double checked, all was working A-OK, and after upgrade it was totally different, not the settings but the UUID.
    My guess is that something during the forceupgrade went awfully wrong, I send Dadmar777 an email for him to investigate too, but it really makes no sense.

    When using Bungee, the only online check should be made right there, and all the underlying servers need to be offline, If I put one of them in online mode, I can't get to it, Bungee telling me that the server is online and not accessible.

    So, did something changed meanwhile or is there a grave error sneaking in there...
    I tested our Amigos server, and when I put that server online and without Bungee, the UUID works, not telling about the vast errors I get on the console, so this is all in test mode and while I write this, I'm trying to forceupgrade our New Holland server, see if that is error free, but I am sure that there are vast amount of errors too....

    So, this whole nice server idea I had to host for the lot of you, is slowly dying. As I said before, I am busy making things work and after a month or so it kinda works, and then there's the next upgrade, starting shit from the beginning....

    Absolutely NOT FUN!...... but I am still trying to heal.:unsure:
     
  11. Had to say something, even a million dollar racecar can quit working without any sign, same with worlds, so many factors, so many possibilities that can influence the upgrade process, that one plugin that did not work properly left a footprint over which the upgrade process tackles and fall in errors.....
    So, incompetence of knowledge is also a factor that makes people do what they do, they don't expect problems, they just occur, the reaction on that however is totally human.
    Its in our DNA :)
     
    • Like Like x 1
  12. First error that came out of the 1.15.2 forceupgrade is.....
    [10:54:29] [chunk IO worker/WARN]: Saving oversized chunk [-7, 1] (1594638 bytes} to external file .\World\region\c.-7.1.mcc
    [10:59:28] [chunk IO worker/WARN]: Saving oversized chunk [-7, 1] (1595272 bytes} to external file .\World\region\c.-7.1.mcc
    Now, my biggest question is, how is this possible, how can a chunk be oversized? I have no idea and can not explain this, maybe anyone of you can? Please!

    update: I have this program chunky at my fingers, checked that world with it, for those who do not know chunky (i am not sure if I can tell this, but alas https://chunky.llbit.se/ ) The beauty of this little program is that chunks that are bad (in this case) can be deleted from the map and let MC generate it again according to the seed given by its world property.... This worked all the times...
    Now earlier, I think 1.13 or 1.14 maybe I had this one chink I mentioned before [-7,1] also giving an error, during server startup it error and I decide to try to delete that chunk and let MC generate that chunk again. That worked, from former backup I made the road that lead through that chunk and restored only that little piece, not in the air nor in the depth, only the road.
    After this it error-ed not so clearly that worked. Now this same chunk is acting up again.....
    Am I the only one on the whole planet experiencing this? like suddenly dragons stuck in the world, three of them, and cattle underground in caves?

    See? I can not cope with these kinda weird things anymore, I start to loose the spirit, the MC spirit...
     
    #252 Ms_Killer01, Jul 6, 2020
    Last edited: Jul 6, 2020
  13. Backed up then killed the old Nether. Forced upgrade, now the process of re-exploring the nether begins. Planned to rebuild my network of nether roads/paths for moving between areas, by traveling to overworld bases and entering the portals at each, then working backwards to home base at the spawn area to connect them. Built a road network in overworld pre-update to make travel easier, assuming that the nether will be non-navigable for a while.

    Only real surprise so far (aside from the fact that the nether is dangerous again - which makes it fun!) is that nether fortress locations follow a new pattern in this update. Prior overworld updates had left villages, ocean temples, etc. in the same place when chunks were deleted and regenerated, but the bases that used to be right next to nether fortresses are so far nowhere near them. A bit of a bummer given that some of the bases only existed because of the fortress to begin with. On the plus side, I found and partly explored a bastion remnant near one portal. It's been a long time since I died that many times in a row, brings some welcome risks to the exploration!
     
  14. Ok, never mind, all these errors, it's nothing, I started a few months back to take a backup and lead that through the game's single player edit mode and upgraded it that way.....
    Worked too....

    Ps. does this mean to any of you a thing?
    Code (Text):
    [18:58:36] [Server thread/ERROR]: No key position_predicate in MapLike[{location_predicate:{predicate_type:"minecraft:block_match",block:"minecraft:water"},output_state:{Properties:{level:"0"},Name:"minecraft:water"},input_predicate:{predicate_type:"minecraft:block_match",block:"minecraft:dirt"}}]; No key position_predicate in MapLike[{location_predicate:{predicate_type:"minecraft:block_match",block:"minecraft:water"},output_state:{Properties:{level:"0"},Name:"minecraft:water"},input_predicate:{predicate_type:"minecraft:block_match",block:"minecraft:grass_block"}}]; No key position_predicate in MapLike[{location_predicate:{predicate_type:"minecraft:always_true"},output_state:{Properties:{snowy:"false"},Name:"minecraft:grass_block"},input_predicate:{predicate_type:"minecraft:random_block_match",probability:0.2f,block:"minecraft:grass_path"}}]; No key position_predicate in MapLike[{location_predicate:{predicate_type:"minecraft:block_match",block:"minecraft:water"},output_state:{Name:"minecraft:spruce_planks"},input_predicate:{predicate_type:"minecraft:block_match",block:"minecraft:grass_path"}}]
     
  15. Choco

    Moderator

    Vanilla bug. It can be ignored.
     
  16. Fahrenheit451

    Supporter

    I get the same error when using custom generator-settings in server.properties - in my case generator-settings=2;0;1. My lobby server upgrades fine when generator-settings is empty. I use 2;0;1 as that generates a purely water world (my lobby is an island).

    If you have resolved your issue let us know how.

    F451
     
  17. I was taught a valuable lesson by altering/changing windows back in the day, it may work now, but u never know how far those repercussions go in millions of lines of code you know nothing about(for us end users).
     
  18. So I did resolve this issue by removing the server.properties file, letting the server run and generate a new one. Then I altered the new server.properties to the original settings and it works fine now. Obviously didn't like something in one of the variables.
     
  19. Well, got THAT figured out. New nether is apparently using an entirely different seed than the overworld. So entirely deleting one dimension does not result in the regeneration of dimension using the original seed. Is this expected behavior? Is there a way to force-regenerate the nether using the original seed?
     
  20. md_5

    Administrator Developer

    Set seed in server.properties. Worlds in Spigot are independent of each other
     
Thread Status:
Not open for further replies.