Spigot & BungeeCord 1.17 & 1.17.1

Discussion in 'News and Announcements' started by md_5, Jun 11, 2021.

  1. No really issues for me to far on everything at 1.17.1

    If you are on 1.17.0 ~ there's a crafting dupe, so please upgrade to .1
     
    • Like Like x 1
  2. openj9 uses less memory
     
  3. I find it really reckless to require Java 16 when its not LTS.

    What could possibly be the reason to require a non LTS? its not best practice for *min management, since Java 17 is LTS and its right around the corner... (Sept 2021)
     
  4. Spigot has to follow Mojang, unless they're going to invest time into rewriting Java 16 code to Java 11. For Mojang the version doesn't matter too much, since they bundle the Java version.
     
  5. Im not laying blame, just surprised at how a massive company can make such moronic moves, lol
     
  6. Tough luck for you then.

    There's nothing reckless about it, seriously an overreaction.
     
    • Agree Agree x 3
  7. It's just a version like every other version.
    It is as stable as a LTS.
    Just update every half year and you're good.
     
  8. Shaggy67

    Benefactor

    I'm not sure what the issue is. Minecraft 1.18 is scheduled to come out later this year anyway. Just update to Java 17 then. If you do that, then whether Java 16 is LTS or not for the next 6 months becomes a moot point.
     
  9. Mojang may even change the packaged Java version when they launch MC 1.18?
     
  10. SlimeDog

    Moderator Patron

    They may. They are free to do so, as they were to require Java 16 for MC 1.17.
     
  11. Optic_Fusion1

    Resource Staff

    Pretty much, and for those that don't realize why they're free to do so. It's because it's their game, their product. They can do as they please
     
  12. It was tougher to do in the past, it's easier for them to switch now. They might not constantly 'keep current', they will do what makes sense and when it makes sense for them.
     
    • Funny Funny x 1
    • Winner Winner x 1
  13. Hi md_5,
    Mate I have updated my PC Java version to 16 and I still get the following error when I try and run buildtools. I have also used the work-around but it does not seem to work, mate any advice would be appreciated:

    Command Line Used: java --illegal-access=permit -jar BuildTools.jar --rev 1.17

    Prior to Failure:
    $ java --illegal-access=permit -jar BuildTools.jar --rev 1.17
    OpenJDK 64-Bit Server VM warning: Option --illegal-access is deprecated and will be removed in a future release.
    Loading BuildTools version: git-BuildTools-b849734-131 (#131)
    Java Version: Java 16
    Current Path: G:\07. MINECRAFT\BUILDTOOLS\BUILDTOOLS - 11 AUG 21\.
    git version 2.32.0.windows.2


    [INFO] BUILD FAILURE
    [INFO] ------------------------------------------------------------------------
    [INFO] Total time: 0.349 s
    [INFO] Finished at: 2021-08-11T20:19:04+10:00
    [INFO] ------------------------------------------------------------------------
    [ERROR] Failed to execute goal org.apache.maven.plugins:maven-install-plugin:2.4:install-file (default-cli) on project standalone-pom: Error installing artifact 'org.spigotmc:minecraft-server:csrg:maps-spigot-fields': Failed to install metadata org.spigotmc:minecraft-server/maven-metadata.xml: Could not write metadata C:\Users\Admin\.m2\repository\org\spigotmc\minecraft-server\maven-metadata-local.xml: C:\Users\Admin\.m2\repository\org\spigotmc\minecraft-server\maven-metadata-local.xml (Access is denied) -> [Help 1]
    [ERROR]
    [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
    [ERROR] Re-run Maven using the -X switch to enable full debug logging.
    [ERROR]
    [ERROR] For more information about the errors and possible solutions, please read the following articles:
    [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
    Exception in thread "main" java.lang.RuntimeException: Error running command, return status !=0: [G:\07. MINECRAFT\BUILDTOOLS\BUILDTOOLS - 11 AUG 21\apache-maven-3.6.0/bin/mvn.cmd, -Dbt.name=3170, install:install-file, -Dfile=work\bukkit-e3c5450d-fields.csrg, -Dpackaging=csrg, -DgroupId=org.spigotmc, -DartifactId=minecraft-server, -Dversion=1.17-R0.1-SNAPSHOT, -Dclassifier=maps-spigot-fields, -DgeneratePom=false]
    at org.spigotmc.builder.Builder.runProcess0(Builder.java:919)
    at org.spigotmc.builder.Builder.runProcess(Builder.java:850)
    at org.spigotmc.builder.Builder.runMaven(Builder.java:819)
    at org.spigotmc.builder.Builder.main(Builder.java:460)
    at org.spigotmc.builder.Bootstrap.main(Bootstrap.java:27)
     
  14. Try running the jar command with Administrator permissions (start CMD with Administrator)
     
  15. Thanks for the reply, what would the command line in Git Bash be?
     
  16. you need to start git bash as administrator
     
  17. Thanks for the reply, unfortunately that didn't work I still have the same error
     
  18. Shaggy67

    Benefactor

    I don't really have an answer for your actual problem, but would recommend changing your --rev to 1.17.1 instead of just 1.17. There were some pretty big bug fixes in 1.17.1 that you probably want to have.
     
    • Agree Agree x 2
  19. Thanks for the replies but nothing seems to work, I still get the error