Bungee - Bukkit [Spigot/Bungeecord] TelegramSupport 3.2

Support your Server/Proxy with Telegram

  1. undeaD_D submitted a new resource:

    BungeeTelegramSupport - Support your Server with Telegram

    Read more about this resource...
     
  2. Der Downloadlink geht nicht
     
  3. The public Version is currently under Construction ;)

    If you want me to add your Ideas feel free to ask ...
     
  4. Nice!


















    Because i helped. :D
     
    • Optimistic Optimistic x 1
  5. undeaD_D updated [Spigot/Bungeecord] TelegramSupport with a new update entry:

    UpdateChecker

    Read the rest of this update entry...
     
  6. Lookin' very cool :)
     
    • Agree Agree x 1
  7. Cool idea.

    Tried to get it to work.
    Did /support join in Minecraft.
    When I type after that in Minecraft, I don't see what I just typed, is that right?
    The message does not show up in Telegram.
    When I talk in Telegram in the groupchat, you see the message in Minecraft.

    -edit- I didn't realise, but I checked the console after some testing, here's the error message as soon as I type something in the support channel in Minecraft:

    [16:44:55] [Async Chat Thread - #1/ERROR]: Could not pass event AsyncPlayerChatEvent to TelegramSupport v1.5
    org.bukkit.event.EventException
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:310) ~[spigot-1.9.jar:git-Spigot-b1c1b55-dd016e7]
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62) ~[spigot-1.9.jar:git-Spigot-b1c1b55-dd016e7]
    at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:502) [spigot-1.9.jar:git-Spigot-b1c1b55-dd016e7]
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:484) [spigot-1.9.jar:git-Spigot-b1c1b55-dd016e7]
    at net.minecraft.server.v1_9_R1.PlayerConnection.chat(PlayerConnection.java:1264) [spigot-1.9.jar:git-Spigot-b1c1b55-dd016e7]
    at net.minecraft.server.v1_9_R1.PlayerConnection.a(PlayerConnection.java:1202) [spigot-1.9.jar:git-Spigot-b1c1b55-dd016e7]
    at net.minecraft.server.v1_9_R1.PacketPlayInChat$1.run(PacketPlayInChat.java:39) [spigot-1.9.jar:git-Spigot-b1c1b55-dd016e7]
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_72]
    at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_72]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:1.8.0_72]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:1.8.0_72]
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_72]
    Caused by: retrofit.RetrofitError: 403 Forbidden
    at retrofit.RetrofitError.httpError(RetrofitError.java:40) ~[?:?]
    at retrofit.RestAdapter$RestHandler.invokeRequest(RestAdapter.java:388) ~[?:?]
    at retrofit.RestAdapter$RestHandler.invoke(RestAdapter.java:240) ~[?:?]
    at com.sun.proxy.$Proxy31.sendMessage(Unknown Source) ~[?:?]
    at com.pengrad.telegrambot.TelegramBot.sendMessage(TelegramBot.java:47) ~[?:?]
    at net.Animes4Me.Utils.Telegram.send(Telegram.java:76) ~[?:?]
    at net.Animes4Me.Spigot.SupportCommand.onChat(SupportCommand.java:118) ~[?:?]
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_72]
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_72]
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_72]
    at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_72]
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:306) ~[spigot-1.9.jar:git-Spigot-b1c1b55-dd016e7]
    ... 11 more
    -edit-
     
    #10 Boaike, Mar 13, 2016
    Last edited: Mar 13, 2016

  8. did you edit the config.yml ?...

    "retrofit.RetrofitError: 403 Forbidden"
    because this can only happen if your token and or chatid is wrong ^^

    EDIT: also make sure to download the latest version (1.5) ^^
     
    #11 undeaD_D, Mar 13, 2016
    Last edited: Mar 13, 2016
    • Like Like x 1
  9. You are absolutely right. I didn't realise the chat id number could be a minus-number too. After I changed that it worked flawlessly. Thanks again!
     
  10. em whenever i try to use any command even after adding the permissions to my PEX aswell as the bungeecord perms
    i cannot get access to the plugin /sup or /support
    i keep getting
    you do not have permissions to execute this command
     
  11. sry ... for some reason i did not get alerts that someone posted messages -.- give me a sec ^^ i will look into that right now ;)
     
  12. do you use the plugin on a bungeeserver or on a spigot server ?
    what permissions did you add? (small example ...)
     
  13. i added all the permissions on ur front page.
    installed it on bungeecord
     
  14. bungee works fine for me ... ^^ are you sure that you have done it correctly ? :D
    can you give me a paste of your /config.yml and the plugins/telegramsupport/config.yml ?!

    you could use pastebin or ybin.me for example ...
     
  15. em i have it like :
    Code (Text):
    permissions:
      default:
      - telegramsupport.join
      - telegramsupport.leave
      - telegramsupport.color
      - bungeecord.command.server
      - bungeecord.command.list
      admin:
      - telegramsupport.toggle
      - telegramsupport.join
      - telegramsupport.leave
      - telegramsupport.color
      - bungeecord.command.alert
      - bungeecord.command.end
      - bungeecord.command.ip
      - bungeecord.command.reload
    groups:
      mmuziek:
      - admin
    this but it aint working ?
     
  16. you need to add the help permission to the default group ^^ ... it wont work without it ...
     

Share This Page