Spigot Community Server

Discussion in 'News and Announcements' started by md_5, Apr 25, 2017.

Thread Status:
Not open for further replies.
  1. wohoo ... thats what im waiting for

    i go online soon
     
  2. I note the community server is 45 versions behind. I'm having a problem with the recipe book on my current Spigot server. In Single Player Vanilla with my client, I can quickly combine coal into coal blocks. I can do the same on the Spigot community server. But when I try use shift-left-click on the coal block of the recipe book (combine all the coal you can), it flashes into the crafting table and right back out. I do note it worked earlier as it does on the current community Spigot server. I also tested this without any plugins and the Vanilla (unmodded) client.

    If this is already reported in Jira, I apologize. My search-FU is weak and I couldn't find this bug. I would be happy to report it, I just want to make sure I did all the appropriate testing I needed to do before bothering anyone in the bug tracker. If possible, it would be very helpful to have the community server updated to the current running Spigot for testing purposes.

    Thank you.
     
  3. I think this was intentional to fix a dupe bug but Im not sure.
     
  4. smmmadden

    Benefactor

    if you're using EssentialsX the /recipe command was removed due to a bug in spigot/minecraft that exploited a hole that you could get the recipe items for free. No word yet on when it'll get added by in for /recipe if that's what you used. The UI for the crafting table to get recipes should still be functional though unless of course you have a resource pack not updated to 1.12 and make the recipe book slot enabled to the right of the Shield slot. If it appears empty, it can still work by registering the event when the slot is clicked (even though it is not visible).
     
  5. The recipe book was disabled by default on spigot to "fix" a duplication bug. There is a permission node you can give players to regain it's usage, but the dupe bug is still there so it's recommended not giving this permission.

    The is a plugin (ExploitPatcher by @Chazmondo ) that has a better fix for this issue, making it safe to give players the permission.

    For an even better fix use Paper build 1168 or higher as they've fixed the root cause of the dupe glitch.
     
    #305 BillyGalbreath, Aug 1, 2017
    Last edited: Aug 1, 2017
    • Friendly Friendly x 1
  6. Ah, thank you. :) I'm only using EssentialsX for the GOD mode for a player, but on 1.13 and the ability to make command "packs", I plan to switch to OnePlayerSleeping and my home-brew "God" mode in .mcfunction calls. In my testing, I removed EssentialsX, and as mentioned, it is a problem with Spigot and the dupe bug. I suspected that was the problem, but I wasn't certain how to confirm that. When I initially tested the Spigot Community Server, it worked. I didn't FIRST check to see how far behind it was.

    I'm guessing the dupe bug is a Vanilla issue that Spigot can't fix because "Vanilla"? I'll look into the ExploitPatcher plugin and just grant everyone permission. I would consider Paper, but I'm nudging the players on my server towards Minecraft Windows 10 and Realms. It's a tiny server, I'm getting major overtime at work and that doesn't leave me much time to sort out problems like this that always crop up regardless of what server you are using... except Realms, because you can't do anything about it except complain to Mojang. Server admin burnout is pretty much getting me to that point. :(
     
  7. 2008Choco

    Junior Mod

    This issue is a server-client desync issue that cannot be fixed by a mere plugin, nor the server alone. A client and server release must be made in order to fix it (thus the 1.12.1 release soon to come this week or the next). Sure, that resource fixed one of the issues, but there are numerous issues regarding the crafting recipes window that a plugin cannot fix. This has been mentioned before by md_5 and is the reason why it has been disabled based on a permission.
    https://www.spigotmc.org/threads/pl...ecipe-book-but-admin-can.260663/#post-2572573

    If it were easily fixable, don't you think there would have been a patch on Spigot's end by now? Rushing to just shove a permission node seems like an awful fix and I'm sure md_5 is very much aware of that, but it's the better alternative than allowing players to exploit a duplication glitch that should not have passed 1.12 release.
     
  8. Thank you, @2008Choco. I'm reading through the shouting on the plugin by @Chazmondo, and it seems there is quite a bit of noise going on. I don't know if you would be willing to restate your post on https://www.spigotmc.org/threads/exploitpatcher-1-12-related-450-downloads.259240/page-3, but that Spigot thread and post by md_5 would clarify the situation. It may not hurt if md_5 were to put a tiny.url in the boot log to a post on the front page. Only server ops would be notified, I'd have caught THAT and gotten my info "straight from the horse's mouth" instead of flailing around trying to figure out why my recipe books don't work anymore. But thank you for your insight, now I have to see what my server boss (my wife) wants me to do about it.
     
  9. Dupe is already patched with a plugin from @Chazmondo
     
    • Informative Informative x 1
  10. Yes, I saw. I conferred with The Boss (my wife who also plays the server) to just leave things alone until Spigot 1.12.1. The drama in the discussion part of that patch is part of why I'd be just as happy to dump Spigot, Minecraft Java and all the noise I have to do as admin to go with Windows10 Realms. A 65 hr./ week shift leaves me a bit short on time and patience for game server admin and drama.
     
  11. NICE! I will be there
     
  12. Delivering custom advancements to RPG or skyblock server would be awesome. I confirme !



    __________________________________________________
    TubeMate Psiphon Test DPC
     
    #313 leonette, Jul 10, 2018
    Last edited: Jul 12, 2018
  13. Um Necro posting? This is old prior to 1.12 release...
     
    #314 Supertrain212, Jul 11, 2018
    Last edited: Jul 13, 2018
    • Funny Funny x 2
  14. Source: https://minecraft.net/tr-tr/article/minecraft-113-pre-release
     
    • Informative Informative x 1
  15. @Supertrain212 Uhm... I think that was "NECRO-posting." ;-) Damn autocorrect!

    By the way, I see Spigot is on Pre7, and I've been reporting this to my server players. We really look forward to switching from Vanilla to Spigot 1.13 for /tps and some of the plugins we want to use.
     
    • Agree Agree x 2
  16. Yeah was typing on my dumb phone.
     
    • Funny Funny x 1
  17. md_5

    Administrator Developer

    • Agree Agree x 1
    • Winner Winner x 1
Thread Status:
Not open for further replies.

Share This Page