Spigot, CraftBukkit, BungeeCord 1.9.2

Discussion in 'News and Announcements' started by Thinkofdeath, Mar 30, 2016.

Thread Status:
Not open for further replies.
  1. Thinkofdeath

    Developer

    Hi everyone,

    A short while ago Mojang released Minecraft 1.9.2 containing a few minor fixes, and we have now also updated. There is full 1.9 plugin compatability and client support with this version, so everyone is recommended to upgrade. BungeeCord is also updated and can be found on Jenkins.

    In order to get this updated server, simply run the latest BuildTools, eg:
    Code (Text):
    java -jar BuildTools.jar
    If you haven't used BuildTools to create a server jar yet, it is suggested you first read the 1.8 announcement and the additional BuildTools info thread.

    If you have any issues, please don't hesitate to ask for support on either the IRC channel (chat tab above), or the forums. The bug tracker (on hub.spigotmc.org) is also available, however please keep entries there limited to actual, verified bugs.

    Hope you enjoy,
    ~Spigot Team

    If for some reason you still require 1.9 you should run BuildTools with --rev 1.9, eg:
    Code (Text):
    java -jar BuildTools.jar --rev 1.9
    please note that there will be no further updates to such builds.
     
    • Like x 62
    • Winner x 14
    • Optimistic x 4
    • Agree x 3
    • Friendly x 2
    • Useful x 2
    • Funny x 1
    • Informative x 1
    • Creative x 1
  2. foncused

    Junior Mod Patron

    Awesome, thanks!
     
    • Like Like x 1
  3. Great! As always Spigot going lightning fast
     
    • Agree Agree x 5
  4. Thanks m8
     
    • Agree Agree x 1
  5. I just tried running this, but still getting version 1.9 when it's just

    java -jar BuildTools.jar

    Edit: just had to re-run it again. Works great!
     
    #5 jhizzal, Mar 30, 2016
    Last edited: Mar 30, 2016
    • Like Like x 1
  6. 2008Choco

    Resource Staff

    You guys are the true MVP's ;) Great work ^-^ Thanks
     
  7. nice, will users on 1.9 be able to join still?
     
    • Funny Funny x 2
  8. Thinkofdeath

    Developer

    @jhizzal Was a bit trigger happy on the post, you should now be able to get it
     
    • Funny Funny x 4
    • Like Like x 1
  9. This guy...
     
    • Agree Agree x 4
    • Funny Funny x 4
  10. 2008Choco

    Resource Staff

    Did you read the thread at all?
     
  11. I only read the title :p
     
    • Optimistic Optimistic x 5
    • Funny Funny x 3
    • Winner Winner x 2
    • Friendly Friendly x 1
  12. MineCove

    Patron

    Thank you for the speedy release guys
     
    • Winner Winner x 1
    • Friendly Friendly x 1
  13. AWESOME! THANK YOU SO MUCH! <3
     
    • Agree Agree x 1
  14. Thanks for this fast update!
     
  15. Awesome, thanks for the update, much appreciated :D
     
  16. Awesome update! Thanks so much! :D
     
    • Like Like x 1
  17. It looks like when pulling it down through the BuildToolsGUI Tool it's just exporting spigot-1.9.jar. I built it and put it on my server, but when trying to connect from a 1.9.2 client it won't allow me to, saying the server is running Spigot 1.9

    I'm now trying building spigot via Git/BuildTools.jar and will see if that gives me the latest version.

    EDIT/UPDATE: It just finished building it via Git, and sure enough it output spigot-1.9.2.jar. Looks like the GUI version of BuildTools isn't pulling latest.
     
  18. Very Good! Thanks :)
     
  19. Fast as always, nice work.
     
Thread Status:
Not open for further replies.

Share This Page