Spigot does not load

Discussion in 'Spigot Discussion' started by thenetherman, Jun 4, 2013.

  1. Server log says it is an invalid jar.

    Now what?
     
    • Funny Funny x 2
  2. Actually, it says: “could not load ‘plugins\spigot.jar’ in folder ‘plugins’ org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml”
    org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml
     
    • Funny Funny x 2
  3. CustomForms

    CustomForms Retired Moderator
    Retired Supporter

    Post your server log.

    Edit: spigot isn't a plugin....its a loader just like bukkit.
     
    • Agree Agree x 1
  4. Puremin0rez

    Moderator

    You're trying to install it as a plugin - Spigot is not a plugin.

    You need to replace your Craftbukkit with Spigot.
     

  5. Well there's your problem. o_O
     
  6. Now why would I do that - replace bukkit with spigot?
     
  7. LiLChris

    LiLChris Retired Moderator
    Retired

    Because it's meant to replace Bukkit, not a plugin for you to add.
     
  8. So delete bukkit.yml and install spigot?
     
  9. delete bukkit.jar and use spigot.jar instead
     
  10. The is no bukkit.jar - just a craftbukkit.jar
     
  11. CustomForms

    CustomForms Retired Moderator
    Retired Supporter

    Replace that with the spigot.jar
     
    • Agree Agree x 1
  12. I did - now it shows it is running minecraft 1.4.6 - and I can’t log into my server because I am using a 1.5.2 client!
     
  13. LiLChris

    LiLChris Retired Moderator
    Retired

    http://ci.md-5.net/job/Spigot/
     
  14. Still says it is 1.4.6!
     
  15. LiLChris

    LiLChris Retired Moderator
    Retired