1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

spigot doesn't connect to domain?

Discussion in 'Bugs & Feature Requests' started by Pyr0x3n, Apr 26, 2013.

  1. Hi all,
    I don't really know if it's a spigot bug, but since release 795 my players can't connect with the server domain name, they only can connect with the server IP address.

    could it be related to netty?
     
  2. That would be a DNS issue. My users are having no issues using a FQDN at all.
     
  3. That what i believed too, but I've now tested versions above 794 and the same is happening all times. From 794 and bellow no problems. So it may be something to do with changes in version above 794.

    If I look in the change log for 795:
    1. Implement a "proper" connection throttle for netty. (commit: 296620b306555a56e3104fa46335274907712618) — md_5 / detail
    2. [Experimental] Add connection multiplexer to allow many listen blocks. Secondary listen blocks are configured in bukkit.yml (commit: b9d0fab57967ec2ea607c9421faf63b4bc3ffcd7) — md_5 / detail
    Could it be those change causing communications problem? weird! or could it be the java version I am running?

    java version "1.6.0_45"
    Java(TM) SE Runtime Environment (build 1.6.0_45-b06-451-11M4406)
    Java HotSpot(TM) 64-Bit Server VM (build 20.45-b01-451, mixed mode)
     
  4. md_5

    Administrator Developer

    Its not Spigot. If it was I would know by now.
     
  5. I am narrowing the problem, I use remote toolkit & dynmap. I suspect there is a conflict somewhere with the API. I'll do more test this nigth.
     
  6. CustomForms

    CustomForms Retired Moderator
    Retired Supporter

    Could you post your bukkit.yml?
     
  7. So you already try to disable netty?

    I have similar issue at newest build of Spigot, players cannot connect to server with enabled Netty :D
     
  8. just tried.... no improvement.

    I've 2 servers, this affect only one, the 2 have different plugins and one remote toolkit. I'll test every plugin
     
  9. As jg555 said. If they can connect to the direct IP, but not your Domain, then it is a DNS issue.
     
  10. This is not a DNS problem, I've just solved temporary the problem by setting 'connection-throttle = 0' in the bukkit.yml.
    Not the most comfortable solution but its works. I'll test higher values and comes back.
    Has I said before below 795 and above I have this problem, bellow 795 just working fine (just tested again with 20 different versions!!)

    ***edit
    '0' is the only value working. no other values help.
     
    #11 Pyr0x3n, Apr 26, 2013
    Last edited: Apr 26, 2013