Spigot Essentials failure

Discussion in 'Spigot Plugin Help' started by aliflo, May 24, 2015.

  1. Hello, aliflo here.

    See the bold stuff for relevant information.

    Well, recently I've been helping a friend.. uhhh.. make the transition from 1.7.5 to 1.8 (he's scared of losing craftbukkit and crap like that) and so on a 'scouting mission' I tried to set up a Spigot server. I set it up and to test the plugins, added Worldedit. Then I realised I should probably check essentials works and... well... Essentials didn't work. I downloaded it from here: https://hub.spigotmc.org/jenkins/job/Spigot-Essentials/
    and pastes these files into my Plugins folder:
    Essentials:
    Antibuild
    Chat
    GeoIP
    Protect
    Spawn
    and regular Essentials. None of them were the 'original' files.

    Upon running the server I was greeted with the error message shown in the attached PDF. I dismissed it and went on the server - it worked - and tested worldedit, which still worked, and then tested essentials. When I typed in a command, such as /hat or /gm, nothing happened. I mean nothing at all. THe same with just the regular essentials file on its own. If anyone knows how to 'fix' this, then I would greatly appreciate it.
    In the console, it said I issued a command but nothing happened.

    PLEASE HELP!
     

    Attached Files:

  2. Essentials needs vault.
    Also get latest worldedit/worldguard from bukkit page as they are updated to 1.8.
     
    • Agree Agree x 1
  3. I don't believe Essentials needs Vault, other plugins do need Vault however to hook into Essentials.
     
  4. Try latest spigot (1.8.5 spigot)
    by doing
    Code (Text):

    java -jar BuildTools.jar --rev 1.8.5
     
    That will generate latest essentials, then run it by itself.
    If it works its plugins.
    Then keep adding plugins (one by one) With restarting server.
     
  5. Will try all now, and post again when tested.
     
  6. Just a question where do I put this code, in the 'start.command' file?
     
  7. GitBash in BuildTools.
    Or are you using a shared host?