Solved spigot legacy update.php wont change

Discussion in 'Spigot Plugin Development' started by L0um15, Mar 9, 2020.

  1. Good afternoon. This is my first post on spigotmc.org. First of all i want to apologize for my bad English if any mistakes occurs. Yesterday i discovered a issue with spigot update.php. Whenever i update my resource, update.php will always show "pre1.1" here is a proof https://api.spigotmc.org/legacy/update.php?resource=75847 but my resource is showed as updated to pre1.3 https://www.spigotmc.org/resources/linkedchest.75847/ Now here is a question: am i doing something wrong? can you please tell me how to update resource properly so i can get version checker working again?
     
  2. This is not a resource, remove the tag.
     
  3. It probably just updates every x minutes since it shows the correct version now.
     
  4. Its been maybe 13 hours and still nothing. I tried editing tag with no results and after failure i tried by clicking "Post Resource Update" Button and still with no results.
     
  5. upload_2020-3-9_19-19-41.png
     
  6. The last update you posted was less than 2 hours ago, no idea where you got that 13 hours from. Also your plugin display version and the returned version from the API match.
     
  7. Well i was deleting old versions when i tried to somehow fix it and well..
    Adnotacja 2020-03-09 172402.jpg
     
  8. Adnotacja 2020-03-09 172725.jpg
    So i have to be patient?
     
  9. I think it's some kind of local cache problem. Try to open it in private window or some other browser.
     
  10. It is already updated and returns pre1.3 as mentioned twice by me and someone else (who even posted a screenshot), maybe you should use a browser that isn't caching the page for whatever reason. Your version history also just proves that the API updated in less than 2 hours.
     
  11. I couldn't seen a IMG file because of lack in permission or something. First occurance of issue happened 13 hours ago. And yes it was caching problem. Thank you for help.
     
    • Like Like x 1