Spigot plugin and multicraft

Discussion in 'Spigot Plugin Help' started by zjmonk, Jul 8, 2015.

  1. I just manage to install multicraft with spigot on my vps, everything is fine, I can connect and play the vanilla minecraft.

    Then I run across some problem with plugins. I manually upload plugins into the server's plugin folder:
    /home/minecraft/multicraft/servers/server1/plugins
    Then I restart the server, but the plugins are not working.

    I check the log, every plugin output some similar errors:
    Failed to write config /home/minecraft/multicraft/servers/server1/plugins/Essentials/config.yml

    Is this related to permissions? Or am i doing something wrong the installing plugins? What can I do to solve this? Thanks!
     
  2. Change your mutlicraft config to start the server with sudo privileges, and then restart the mutlicraft daemon with sudo. That should work.
     
  3. Thanks, I'll try that.
    I already run multicraft dameon with sudo when this error occurs, and I didn't see any config options to let server start with sudo privileges?? Can you tell me how to set that?
     
  4. MikeA

    MikeA Retired Moderator
    Retired Benefactor

    Don't upload files using root, that's your problem. Just use the built-in Multicraft FTP....
     
  5. Thanks, I solve it by give plugin folder write privilege. It seems it's read only and plugins cannot create their config file.
     
  6. Hi, I upload files using normal user which I run multicraft dameon.
    Anyway, I solve it by make plugin folder writable, it used to be read only causing plugins cannot create their config file.
     
  7. MikeA

    MikeA Retired Moderator
    Retired Benefactor

    It's because you're uploading the files to your Minecraft server folder which is running as a different system user. The Minecraft user for the specific server does not have access to the files that you uploaded as the other use. Either re-upload them as the proper user or chown them the proper permissions.

    Regardless it doesn't matter, run it as root, just make sure you're not running a friends server and only your own.
     
    • Agree Agree x 1
  8. Thanks for the tip. I'll open multicraft ftp access to upload plugins instead. I run it on my own vps, but running as root seems not very safe.
     
  9. It's not, the root user as access to everything and linux doesn't have an undo feature. You need to get your FTP details from Multicraft as each time a server is created Multicraft creates a new system user, as MikeA has already said.
     
  10. Thanks, Multicraft did creat seperate user for each user, mc1 for my instance. But it's weird that mc1 didnot has write permission to plugin folder... Thanks anyway, I'll use ftp service multicraft provied to upload plugins.
     
  11. chown -R mc{server_id}:mc{server_id} /home/minecraft/multicraft/servers/server{server_id}

    Basically changes group and user recursively for the given directory