Spigot plugin doesn't load with an API

Discussion in 'Spigot Help' started by Ecofg, Feb 17, 2020.

  1. I am using an API for my plugin, and I want to be able to get the API repository from GitHub, I've added the code that jitpack gave me after I entered the repository link here, but now the plugin isn't even being loaded (also, another person explained me, that the repository doesn't have versions and said that I should replace this: "<version>1.5.4</version>" with this: "<version>5b2d642d3df240cfd2545effcdcacec38405f9cf</version>"; This seamed to fix the problem in the compiler at IntelliJ IDEA)

    Now the error occurs while starting the spigot server with this plugin:
    Code (Text):
    Could not load 'plugins\DeathSwap-1.0-SNAPSHOT.jar' in folder 'plugins'
    org.bukkit.plugin.UnknownDependencyException: ActionBarAPI
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:219) [spigot.jar:git-Spigot-c3c767f-33d5de3]
            at org.bukkit.craftbukkit.v1_8_R1.CraftServer.loadPlugins(CraftServer.java:291) [spigot.jar:git-Spigot-c3c767f-33d5de3]
            at net.minecraft.server.v1_8_R1.DedicatedServer.init(DedicatedServer.java:152) [spigot.jar:git-Spigot-c3c767f-33d5de3]
            at net.minecraft.server.v1_8_R1.MinecraftServer.run(MinecraftServer.java:505) [spigot.jar:git-Spigot-c3c767f-33d5de3]
            at java.lang.Thread.run(Unknown Source) [?:1.8.0_241]
     
  2. md_5

    Administrator Developer

    You haven’t installed the ActionBarAPI plugin, assumings its an actual plugin (you listed it in your plugin.yml depends)
     
  3. md_5 already answered your question, but I'll just link the plugin here.
    https://www.spigotmc.org/resources/actionbarapi-1-8-1-14-2.1315/