Solved Start Issues

Discussion in 'BungeeCord Help' started by nevimjak, May 4, 2021.

  1. Hello, when I try to start my bungee, it gives me this error

    Do you have any solution for this?

    23:25:47 [SEVERE] java.lang.reflect.InvocationTargetException
    23:25:47 [SEVERE] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    23:25:47 [SEVERE] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    23:25:47 [SEVERE] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    23:25:47 [SEVERE] at java.lang.reflect.Method.invoke(Method.java:498)
    23:25:47 [SEVERE] at com.hicoria.javaSandBox.Main$1.run(Main.java:71)
    23:25:47 [SEVERE] at java.lang.Thread.run(Thread.java:748)
    23:25:47 [SEVERE] Caused by: java.lang.RuntimeException: Invalid configuration encountered - this is a configuration error and NOT a bug! Please attempt to fix the error or see https://www.spigotmc.org/ for help.
    23:25:47 [SEVERE] at net.md_5.bungee.conf.YamlConfig.load(YamlConfig.java:73)
    23:25:47 [SEVERE] at net.md_5.bungee.conf.Configuration.load(Configuration.java:71)
    23:25:47 [SEVERE] at net.md_5.bungee.BungeeCord.start(BungeeCord.java:272)
    23:25:47 [SEVERE] at net.md_5.bungee.BungeeCordLauncher.main(BungeeCordLauncher.java:62)
    23:25:47 [SEVERE] at net.md_5.bungee.Bootstrap.main(Bootstrap.java:15)
    23:25:47 [SEVERE] ... 6 more
    23:25:47 [SEVERE] Caused by: while scanning an alias
    in 'reader', line 29, column 5:
    - *
    ^
    unexpected character found
    (10)
    in 'reader', line 29, column 6:
    - *
    ^

    23:25:47 [SEVERE] at org.yaml.snakeyaml.scanner.ScannerImpl.scanAnchor(ScannerImpl.java:1433)
    23:25:47 [SEVERE] at org.yaml.snakeyaml.scanner.ScannerImpl.fetchAlias(ScannerImpl.java:916)
    23:25:47 [SEVERE] at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.java:364)
    23:25:47 [SEVERE] at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:227)
    23:25:47 [SEVERE] at org.yaml.snakeyaml.parser.ParserImpl$ParseIndentlessSequenceEntry.produce(ParserImpl.java:532)
    23:25:47 [SEVERE] at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:158)
    23:25:47 [SEVERE] at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:148)
    23:25:47 [SEVERE] at org.yaml.snakeyaml.composer.Composer.composeSequenceNode(Composer.java:208)
    23:25:47 [SEVERE] at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:160)
    23:25:47 [SEVERE] at org.yaml.snakeyaml.composer.Composer.composeValueNode(Composer.java:257)
    23:25:47 [SEVERE] at org.yaml.snakeyaml.composer.Composer.composeMappingChildren(Composer.java:248)
    23:25:47 [SEVERE] at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:236)
    23:25:47 [SEVERE] at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:162)
    23:25:47 [SEVERE] at org.yaml.snakeyaml.composer.Composer.composeValueNode(Composer.java:257)
    23:25:47 [SEVERE] at org.yaml.snakeyaml.composer.Composer.composeMappingChildren(Composer.java:248)
    23:25:47 [SEVERE] at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:236)
    23:25:47 [SEVERE] at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:162)
    23:25:47 [SEVERE] at org.yaml.snakeyaml.composer.Composer.getNode(Composer.java:95)
    23:25:47 [SEVERE] at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:119)
    23:25:47 [SEVERE] at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:150)
    23:25:47 [SEVERE] at org.yaml.snakeyaml.Yaml.loadFromReader(Yaml.java:472)
    23:25:47 [SEVERE] at org.yaml.snakeyaml.Yaml.load(Yaml.java:411)
    23:25:47 [SEVERE] at net.md_5.bungee.conf.YamlConfig.load(YamlConfig.java:70)
    23:25:47 [SEVERE] ... 10 more
     
  2. This seems to be a YAML error. Probably a spacing issue.
     
  3. But it works till now when restart was really needed
     
  4. Can you pastebin your config.yml file?
     
  5. I might be wrong, however, I believe the following is causing issues for you:
    - *

    Could you try removing it and retrying it?
     
    • Like Like x 1
  6. yep, same error
     
  7. Thaaanks a loot. It worked after second restart
     
  8. Awesome! Glad it helped :)
     
    • Friendly Friendly x 1