Starting a new server - Essentials

Discussion in 'Spigot Discussion' started by Sentient, May 14, 2016.

  1. I wanted to install Essentials on the server that I'm making and I just had a few quick questions. Because of mods I am rolling back the server to 1.8.9 and I have been looking around and I can't find the download marked with that version number. So what version of Spigot and essentials should I download for 1.8.9? I am a novice so please ask me anything if I'm not getting my point across correctly.

    Thanks in advance,
    Senti
     
  2. Hi there :)

    For essentials, I'd recommend EssentialsX - It's a fork of Essentials, but not maintained by the essentials team.
    You can find a list of downloads here: https://www.spigotmc.org/resources/essentialsx.9089/history

    And for Spigot version, you need to go compile the jar file yourself. You can find info about how to do that here:
    https://www.spigotmc.org/wiki/buildtools/
    Even though the easiest way to do it is using a program called BuildToolsGUI - it's pretty straight forward, simply select your desired version and let it do it's thing for a few minutes. You can download BuildToolsGUI from here:
    https://www.spigotmc.org/resources/buildtoolsgui.22267/

    Hope this helps.

    -Mikkel
     
  3. Well thank you very much this is the information that I need. I will start on that today!

    Happy Gaming!
    Senti
     
    • Friendly Friendly x 1
  4. Okay so issue, while building, build tools is trying to resource http://hub.spigotmc.org/versions/1.8.9.json but is doesnt find it. Since it trying to get from a web address I am assuming that I cant get that file from the MC install file and put it in myself. Is there another way to get this file or put it in myself? Or, am I sol?
     
  5. So new question that may trump the previous. So I read somewhere that 1.8.8 works the same as 1.8.9 for servers? is this true? Also, how would I get forge to work in tandem if it is true?
     
  6. Um, yes. All 1.8.x versions of minecraft /should/ be able to connect to your 1.8.9 server.

    And you're looking to run it with mods, also?
    Then you would have to use something called Cauldron.
     
  7. Yes all the mods I am using are for minecraft 1.8.9
     
  8. I'm not sure how this would work with Cauldron, but you can make your server compatible with even more minecraft versions with a "protocol hack" - this is a plugin that will make your server compatible with.. either 1.8 -1.9 or 1.9 - 1.9.4