Startup time

Discussion in 'Spigot Discussion' started by Runemoro, Feb 21, 2013.

  1. In some builds, the startup time is 20-30 seconds and all the plugins load at the same time. In other builds, they load 1 by 1, why?
     
  2. Plugins do not load at the same time, but sequentially, sometimes random or based of plugin importance. If they were to load all at the same time, it would either 1, be extremely rare, 2, lag between SSH and your accessing machine, or 3, rouge computing.... o.o Unless I didn't get a memo or something, thats what I am pretty sure it is, for plugins all have to be cached into RAM, doing so all at once is slightly tough on RAM.


    As for load time, if you have plugins such as McMMO, that keeps several gigabytes of data, that usually will take a while to load, as the same for WorldGuard. And sometimes startup time can be based off your machines specs.
     
  3. I updated from 538 to 539 and the plugins seem to load slower.
    Also, they usually load at the same time becsause I see stuff as:
    [INFO] Loading plugin1
    [INFO] Loading plugin2
    [INFO] Done loading plugin1
     
  4. Stick to 485, its the recommended build. And its just interlacing. I thought you meant something like,

    {All at once}
    [INFO] Loading plugin1
    [INFO] Loading plugin2

    Then a second later.
    {All at once}
    [INFO] Done loading plugin1
    [INFO] Done loading plugin2
     
  5. Why does this not happen on some versions? There's no changes in the source code related to plugin loading, but it's slower. Now it's fast again in 554