Bungee - Proxy SubServers 2 2.13.2d

The Server Management Platform

  1. Have you got "-Djline.terminal=jline.UnsupportedTerminal" between "java" and "-jar"? (if yes, tell me what your OS is, and show me config.yml and lang.yml)
     
  2. If you mean in the config.yml, yes its there. I'm using Linux.

    Config:
    Code (Text):
    # SubServer Plugin Configuration
    # This is The Main Config for this Plugin
    # Where is git Located? Mac/Linux users can ignore this option
    Settings:
      Server-Creation:
        git-dir: C:\Program Files\Git
        log: true
      config-version: 1.8.8j+
      GUI:
        Enabled: true
        Trigger-Item: '129'
      Metrics-Enabled: true
      Server-IP: 127.0.0.1
      Lobby-Port: 25565
      Server-UUID: f50d9c68-ccb5-4813-bcef-cb6419f2f7c0

    # This is the settings for the proxy
    Proxy:
      enabled: false
      run-on-launch: false
      dir: path/to/your/folder
      shell: ./start-bungee.sh
      log: true

    # This Is the List of your Servers
    # And their configurations
    Servers:
      'TestServer':
            enabled: true
            port: 32332
            run-on-launch: false
            log: true
            dir: './TestServer'
            shell: 'java -Xmx1024M -Djline.terminal=jline.UnsupportedTerminal -jar spigot-1.8.8.jar -o false'
            stop-after: 0

    # End of Config
     
    lang.yml is the default one.
     
  3. Your config looks good aside from the fact that your proxy isn't setup. If you happen to not be using these settings in favor of running Bungee separately then /go will not work due to the fact that the Main server has to feed the proxy config options.

    If you'd like to continue running the proxy separately, You'll have to put each SubServer's info into Bungee's config.yml manually and use the default /server.
     
  4. Okay, I've tried to set it up that the Plugin handles the Proxy but it throws me an error that it doesn't have the requried permissions to run ./start.sh. Any help on that?
     
  5. Probably don't have permission.
    </undumb>
    (Mostly because of a shared host or a retarded normal vps/kvm/dedicated host.)
     
    • Funny Funny x 1
  6. You should always put
    Code (Text):
    java [args...] -Djline.terminal=jline.UnsupportedTerminal -jar <jarfile> [options...]
    instead of using a shell file. This works because of the way SubServers handles executable strings.
     
    #106 ME1312, Oct 12, 2015
    Last edited: Oct 12, 2015
  7. ME1312 updated SubServers with a new update entry:

    Minor Changes

    Read the rest of this update entry...
     
    #107 ME1312, Oct 12, 2015
    Last edited: Oct 12, 2015
  8. is it possible to make something so that you can run a server on a different computer and that you can join that by using /go or /server?
    because my pc can't run more than 2 servers
     
    #108 laurens, Oct 13, 2015
    Last edited: Oct 13, 2015
  9. Sure, just add whatever other servers you'd like into bungeecord's Config.yml and they should show up in the SubServers /go
     
  10. oke thank you.
    everytime someone joins a server it shows in chat: "player has left the server" does someone know a good plugin that shows how many players there are in a server and to remove that message?
     
  11. I think essentials can silence the join/quit messages:
    - Enable "allow-silent-join-quit" in essentials config.yml
    - Give your players "essentials.silentjoin" and "essentials.silentquit"
     
  12. doesn't work when i join as admin because it gave me vanish
     
  13. try giving them the negative permission: "-essentials.silentjoin.vanish"
     
  14. hi, the plugin is bug, before update the plugin run correct but in the update dont start and give my this error
    [00:58:18 INFO]: [SubServers] Enabling SubServers v1.8.8k
    [00:58:18 INFO]: SubServers ╗ Loading Libraries for 1.8.7
    [00:58:18 ERROR]: Error occurred while enabling SubServers v1.8.8k (Is it up to date?)
    java.lang.NullPointerException
    at java.io.File.<init>(Unknown Source) ~[?:1.8.0_60]
    at net.ME1312.SubServer.Executable.Executable.<init>(Executable.java:17) ~[?:?]
    at net.ME1312.SubServer.Main.EnablePlugin(Main.java:115) ~[?:?]
    at net.ME1312.SubServer.Load.onEnable(Load.java:12) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) ~[server.jar:git-Spigot-3ccbe77-a6a57a9]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:340) [server.jar:git-Spigot-3ccbe77-a6a57a9]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [server.jar:git-Spigot-3ccbe77-a6a57a9]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugin(CraftServer.java:356) [server.jar:git-Spigot-3ccbe77-a6a57a9]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.enablePlugins(CraftServer.java:316) [server.jar:git-Spigot-3ccbe77-a6a57a9]
    at net.minecraft.server.v1_8_R3.MinecraftServer.s(MinecraftServer.java:418) [server.jar:git-Spigot-3ccbe77-a6a57a9]
    at net.minecraft.server.v1_8_R3.MinecraftServer.k(MinecraftServer.java:382) [server.jar:git-Spigot-3ccbe77-a6a57a9]
    at net.minecraft.server.v1_8_R3.MinecraftServer.a(MinecraftServer.java:337) [server.jar:git-Spigot-3ccbe77-a6a57a9]
    at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:256) [server.jar:git-Spigot-3ccbe77-a6a57a9]
    at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:528) [server.jar:git-Spigot-3ccbe77-a6a57a9]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_60]
    I take the config.yml (old) and write to the new and add the new argument ( use-shared-chat )
    sorry for my english but i have a low level ;(
     
  15. It would appear that you haven't updated for the most recent change:
    anyhow, you can reference the latest default version of config.yml for how it's suppose to look.
     
  16. aaa ok but i dont know use the exec, What I write? but in the new tutorial use shell not exec
    sorry for my english
     
  17. I made the switch to Executable (exec) a while ago but never updated the config. Basically exec can be a shell/batch file or executable string. If your updating your configs, it's easiest just to rename "shell" to "exec" because they take the same input.
     
  18. ME1312 updated SubServers with a new update entry:

    Shared Chat & Command Update

    Read the rest of this update entry...
     
  19. hi, but i update the plugin, and yesterday give my error,
    this is the error
    [10:36:46 INFO]: [SubServers] Enabling SubServers v1.8.8l
    [10:36:46 INFO]: SubServers ╗ Loading Libraries for 1.8.7
    [10:36:46 ERROR]: Error occurred while enabling SubServers v1.8.8l (Is it up to date?)
    java.lang.NullPointerException
    at java.io.File.<init>(Unknown Source) ~[?:1.8.0_60]
    at net.ME1312.SubServer.Executable.Executable.<init>(Executable.java:17) ~[?:?]
    at net.ME1312.SubServer.Main.EnablePlugin(Main.java:115) ~[?:?]
    at net.ME1312.SubServer.Load.onEnable(Load.java:12) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) ~[server.jar:git-Spigot-3ccbe77-a6a57a9]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:340) [server.jar:git-Spigot-3ccbe77-a6a57a9]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [server.jar:git-Spigot-3ccbe77-a6a57a9]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugin(CraftServer.java:356) [server.jar:git-Spigot-3ccbe77-a6a57a9]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.enablePlugins(CraftServer.java:316) [server.jar:git-Spigot-3ccbe77-a6a57a9]
    at net.minecraft.server.v1_8_R3.MinecraftServer.s(MinecraftServer.java:418) [server.jar:git-Spigot-3ccbe77-a6a57a9]
    at net.minecraft.server.v1_8_R3.MinecraftServer.k(MinecraftServer.java:382) [server.jar:git-Spigot-3ccbe77-a6a57a9]
    at net.minecraft.server.v1_8_R3.MinecraftServer.a(MinecraftServer.java:337) [server.jar:git-Spigot-3ccbe77-a6a57a9]
    at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:256) [server.jar:git-Spigot-3ccbe77-a6a57a9]
    at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:528) [server.jar:git-Spigot-3ccbe77-a6a57a9]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_60]

    and this is my config.yml
    Settings:
    Server-Creation:
    git-dir: 'C:\Program Files (x86)\Git'
    log: true
    config-version: 1.8.8k+
    GUI:
    Enabled: true
    Trigger-Item: '129'
    Server-IP: '127.0.0.1'
    Lobby-Port: 25564
    #
    # This is the settings for the proxy
    Proxy:
    enabled: true
    run-on-launch: true
    dir: './Bungee'
    exec: 'java -Djline.terminal=jline.UnsupportedTerminal -jar BungeeCord.jar'
    log: true
    #
    # This Is the List of your Servers
    # And their configurations
    Servers:
    'SkyLands':
    enabled: true
    port: 25563
    run-on-launch: false
    use-shared-chat: true
    log: true
    dir: './SkyBlockServer'
    shell: 'java -Djline.terminal=jline.UnsupportedTerminal -jar server.jar'
    stop-after: 0
    'Survival':
    enabled: true
    port: 25562
    run-on-launch: false
    use-shared-chat: true
    log: true
    dir: './SurvivalServer'
    shell: 'java -Djline.terminal=jline.UnsupportedTerminal -jar server.jar'
    stop-after: 0
    'Parkour':
    enabled: true
    port: 25561
    run-on-launch: false
    use-shared-chat: true
    log: true
    dir: './ParkourServer'
    shell: 'java -Djline.terminal=jline.UnsupportedTerminal -jar server.jar'
    stop-after: 0
    i have a windows and with the older versions run correctly, i dont change the config or the lang ;(
     
  20. I've updated your config for you since you appear to be having troubles:
    Code (Text):
    Settings:
      Server-Creation:
        git-dir: 'C:\Program Files (x86)\Git'
        log: true
      config-version: 1.8.8k+
      GUI:
        Enabled: true
        Trigger-Item: '129'
      Server-IP: '127.0.0.1'
      Lobby-Port: 25564
    #
    # This is the settings for the proxy
    Proxy:
      enabled: true
      run-on-launch: true
      dir: './Bungee'
      exec: 'java -Djline.terminal=jline.UnsupportedTerminal -jar BungeeCord.jar'
      log: true
    #
    # This Is the List of your Servers
    # And their configurations
    Servers:
      'SkyLands':
        enabled: true
        port: 25563
        run-on-launch: false
        use-shared-chat: true
        log: true
        dir: './SkyBlockServer'
        exec: 'java -Djline.terminal=jline.UnsupportedTerminal -jar server.jar'
        stop-after: 0
      'Survival':
        enabled: true
        port: 25562
        run-on-launch: false
        use-shared-chat: true
        log: true
        dir: './SurvivalServer'
        exec: 'java -Djline.terminal=jline.UnsupportedTerminal -jar server.jar'
        stop-after: 0
      'Parkour':
        enabled: true
        port: 25561
        run-on-launch: false
        use-shared-chat: true
        log: true
        dir: './ParkourServer'
        exec: 'java -Djline.terminal=jline.UnsupportedTerminal -jar server.jar'
        stop-after: 0
    # End of Config