Suffocated in a wall. Happening on all worlds. No error in console.

Discussion in 'Spigot Help' started by ssamjh, May 2, 2015.

  1. ssamjh

    Moderator

    Edit: This has been resolved. I had set the max-world-size in server.properities to -1, thinking that it would disable it.

    So the other day I started having a really bad problem where whenever someone spawns, it instantly kills them saying "username suffocated in a wall" when they didn't. As well as that when relogging you don't spawn in the same place. When I got on and godded myself. I didn't keep on dying but I can't interact with anything for some reason. Doors wont open, nothing.

    If you need more information just ask.

    Server log

    List of plugins (+ NoCheatPlus, I removed it to see if it was causing the problem and didn't put it back before taking this screenshot)
     
    #1 ssamjh, May 2, 2015
    Last edited: Aug 23, 2015
  2. Tao

    Tao
    Benefactor

    It's possibly something minor, maybe lag or a glitch. Also my name is in your signature twice.
     
  3. ssamjh

    Moderator

    Any ideas for some basic trouble shooting. I could remove most of the plugins and add them back 1 by one but I have a feeling it's a chunk error.
     
  4. one of my worlds is doing this too. worldguard will keep me alive, but the minecraft gui is all red on the sides. disabling worldguard, i instantly die by "suffocating in a wall" anyone know how to reset/modify/fix a world with this bug?
     
  5. Thats should be glitch or bug I think. Try to update your server version?
     
  6. built today: This server is running CraftBukkit version git-Spigot-fdc1440-53fac9f (MC: 1.8.8) (Implementing API version 1.8.8-R0.1-SNAPSHOT)

    also tried my oldest build from Aug 10, still bugged.

    also tried minecraft-region-fixer, still bugged.

    i don't play my server enough to notice when it started failing. i just keep the plugins updated regularly and let my daughter play, her personal world is not glitched, but the "adventure" world i like is glitched.
     
    #6 789101112, Aug 23, 2015
    Last edited: Aug 23, 2015
  7. ssamjh

    Moderator

    you have set the world border to something to something lower than it should be
     
  8. i was hoping so, but it's not that easy. disabled WorldBorder .jar and still bugged.
    renamed plugins folder so to turn off every plugin and world was still bugged. it does not make sense.
     
  9. ssamjh

    Moderator

    try the world in single player
     
  10. OH MY GODDDDDD.... what a PITA.

    After much troubleshooting i have solved this.

    Briefly, my vanilla worldborder was way too small and way far from my actual spawn-point. The solution was to change the worldborder size and center point.

    Details:
    This was a long lived map where i had a far off spawn point at (6200,-6540) and the original spawn (0,0) was way outside my live world range. Additionally, some plugins may have been fighting for setting of the world spawn and resetting it to (0,0). I edited some HomeSpawnPlus configs and some CommandBook configs.

    Finally i found that minecraft has some /worldborder vanilla commands that are not part of the worldborder.jar plugin.

    My final solution was to temporarily disable worldborder.jar, use "/worldborder center 6200 -6540" and "/worldborder set 7300" (same as my worldborder.jar setting) and of course set the world-spawn properly.

    no more glitch.

    Edit: Additional note: i found that mobs were not spawning anymore, i found the vanilla /worldborder set <radius> needed to be big enough to include the original spawn location of (0,0) ; so for me i re-issued with "/worldborder set 99999" just to be safe. The logic is concluded from this discussion which recommended visiting the original spawn.
     
    #10 789101112, Aug 24, 2015
    Last edited: Aug 27, 2015
    • Like Like x 1
    • Winner Winner x 1
    • Informative Informative x 1
  11. ssamjh

    Moderator

    thought it was something like that
    that's good you got it fixed