Suggestion Support for 'ancient' version

Discussion in 'Community Feedback and Suggestions' started by AlphaHelix, Feb 7, 2018.

  1. Personally, as a developer, I think there should be some kind of slow phasing out of support for old Minecraft versions. So, in my opinion, only the latest and possibly the previous version should be supported for a short time. For example, support for versions 1.8 / 1.9 and 1.10 should now be discontinued.
    I would like to see a small limitation for the above-mentioned versions.
    • Agree Agree x 6
    • Funny Funny x 6
    • Winner Winner x 2
    • Optimistic Optimistic x 1
  2. No, just no. There are still many servers using 1.8, that was the period before Minecraft died.
    • Funny Funny x 3
    • Optimistic Optimistic x 3
    • Agree Agree x 1
  3. md_5

    Administrator Developer

    Spigot flat out doesn't support anything < 1.12.2
    It's not us you have to convince, it's other developers and server owners.
    • Agree Agree x 2
  4. Who said there was still support for them now? If you're going to try and stop plugins from supporting it then that's hilarious.
    Edit: Ninja'd
  5. It's not about the plain Spigot version. It's about the plugins. They won't be changing out of the blue.
  6. [​IMG]
    Still using Minecraft 1.8 is as hilarious as still using Java 7, but I won't drop support for it if it comes to my own plugins. I imagine people like you would just use the latest version that still supports 1.8 and spam me with bug reports for this ancient dev build...
    • Agree Agree x 2
  7. Relinquished


    Why do you care if someone wants to use an older version? Or if someone wants to add compatibility with an older version for their plugin. It's not hurting anyone.
    • Like Like x 1
    • Funny Funny x 1
  8. It is necessary to explain to the users that it is difficult to program individually for 4 versions. And it would be much better to update to a new version, saving the developer work and giving users less headaches. In addition, the servers should also go forward and not work on versions of 2014. Besides, how else are you going to get the servers to update their version as if you were just making your plugin available for newer versions only.
    • Agree Agree x 1
    • Optimistic Optimistic x 1
  9. It's simple, a developer has a version and it says "supports 1.12.2" and if they simply don't have a 1.8 version, they dont.. if they do, they do ..

    I find this a non-issue, and spigot supports 1.12.2 as it's the latest stable. if a plugin you want doesn't have the version you run, so be it.. maybe another one does. It's just what it is. you can't force developers to support all versions just because someone doesn't update, or because the developer doesn't have time to support the latest greatest.

    people can always hire developers to take open source projects and adjust them for their own server and version.
    • Like Like x 2
    • Winner Winner x 1
  10. Or when you ask your dev to make a plugin, ask him/her to write a version-independent plugin.
  11. MiniDigger


    Thats simple not possible in all cases, for example when you use new minecraft blocks/features, new spigot Apis or Deal Witz breaking API Changes.
    • Agree Agree x 1
  12. i'm not talking about "all cases". ofc for certain methods they would require update of the plugin.
  13. [​IMG]
    Supporting all versions back to 1.8 isn't really a hassle, most of them are very similar and it's very easy to do. I do it and I think others should do it if they want to, going back to 1.8 is reaching a large playerbase/serverbase so you'll get much more attention if you do support those versions. I think since it's something easy to do and something which would take very little effort, there's no reason not to. Although I do agree, people need to update.
    • Agree Agree x 1
  14. MiniDigger


    what do you do about apis that were added to spigot later? think titles, iconbar msg, spawner api, creeper api, new events (locale, mainhand, piston, broadcast...), spawnegs, itemflags etc. those are just the ones I can think about ontop of my head rn which were added after 1.8
    • Agree Agree x 3
  15. But if you still give support for the old versions, you still support the use of those old versions. And servers won't see any reason for updating.
  16. MiniDigger


    which makes you a part of the problem
    • Agree Agree x 6
  17. Hypixel runs on 1.8, whats so bad about it?
  18. Just because Hypixel does it doesn't mean it's good. They're running 4 year old software, you don't need to be a genius to understand that that's bad practice (they update and patch it themselves from time to time, but still).
    • Like Like x 1
    • Winner Winner x 1
  19. MiniDigger


    hypixel has a huge team who is able to fix issues in the software by themselves. they don't need to reply on the spigot team anymore. are you in such a position too?
    • Like Like x 1
    • Agree Agree x 1
  20. I don't see it as a problem to allow people to play the legacy versions they want to play, it just puts their server at risk for worse optimization and worse results from a plugin. Putting in support for something doesn't mean you actively give support to the people having issues with it.
    I make them >not work< for the plugin and add in a disclaimer that certain features won't work with their server version. For anyone using all of these features it seems pretty far out, but you'd just drop support for 1.8 and any other version you won't support.
    I don't personally support the use of old versions, I do however make plugins for the people, not myself. Making plugins for a community which wants all these versions which puts me into a position where giving the community which I'm advertising to or giving to a larger selection. If people want legacy they will find a reason or find plugins to keep them there. Once they learn it's outdated and gives them less access to certain features, they will switch.

Share This Page