Suggestion Support for 'ancient' version

Discussion in 'Community Feedback and Suggestions' started by AlphaHelix, Feb 7, 2018.

  1. Legoman99573

    Supporter

    As @electronicboy would say "Don't make shit coded plugins"

    PaperSpigot basically applies a bandaid for some thing that are messed up in regular spigot. Take 1.12.0 and craftbook exploit for example. Spigot made a perm while paperspigot fully patched it without a perm (As most people still use /op on their servers)
     
  2. MiniDigger

    Supporter

    Please.
    It's. Just. Paper.
    When will ppl understand that?....
     
  3. Legoman99573

    Supporter

    I have nothing against paper since i am using it myself. Plugins preform just fine or even better than before.
     
  4. MiniDigger

    Supporter

    What has that to do with my correction of you naming it wrong?
     
  5. md_5

    Administrator Developer

    Actually there were additional vulnerabilities / ways to exploit that in the recipe book that they left unpatched (and thus users were exposed to). This is why we went with a disable whilst Mojang worked on a proper fix.

    Not related to this thread anyhow, this site is for discussion of Spigot and Spigot only (see: rules).
     
    • Like Like x 1
  6. Legoman99573

    Supporter

    That part i was unaware of, other than in survival servers, item duplication was a huge problem and was abusable as everyone heard about it.
     
  7. You guys are all bad. There is now an addon for ViaVersion that allows you to support 1.8 clients on a 1.12 server. Combine that with a plugin that removes new mechanics and you're done!!
     
    • Like Like x 1
    • Agree Agree x 1
    • Funny Funny x 1
  8. 2008Choco

    Resource Staff

    Who needs 1.8? Why not go back to 1.7.x so we can have those guys on our servers too! ViaRewind has done nothing but wonders for the PvP communi- yea I hate myself for even trying to pretend that it's a good idea... While we're at it, let's just write another plugin that lets' 1.5.x players join 1.12.x servers
     
    • Winner Winner x 1
  9. MiniDigger

    Supporter

    Can't go further back than the netty rewrite unless you want things to get really ugly
     
  10. 2008Choco

    Resource Staff

    Supporting 6 consecutive versions (soon to be 7) is also really ugly, but clearly that hasn't stopped anyone, so...
     
  11. I honestly wonder how long people will keep up. People still use 1.8 while we're at 1.12. Personally I cannot imagine why some people choose PVP change over literally 3 versions of new features. Guess I'll never understand... I wonder how long they will keep up now that 1.13 and 1.14 are coming...
     
  12. MiniDigger

    Supporter

    Via is actually implemented pretty clean.
     
  13. Fuck it! Let's support the oldest version that supports Multiplayer!!!! Get all those bastards that whinge about bugs in ancient, shitty software to be happy!

    I'm kidding. Fuck 'em all. They wanna use outdated software and expect to be treated like gods for using a pile of shit? Ha. Yeah, no. Update to the latest version and quit whinging.
     
    • Winner Winner x 2
  14. Man, This says it all......
    Put the 1.8 Plugins on a shelf with a disclaimer: No Longer supported in the latest updates, Use At Your Own Risk, and move on with updates.
     
    #74 EODSteven, Feb 26, 2018
    Last edited: Feb 26, 2018
    • Agree Agree x 1
  15. TechsCode

    TechsCode Previously TechXcrafter

    If this trend keeps going the version will someday be older than the players playing it.
     
  16. Legoman99573

    Supporter

    1.13 should be the killer (cause block IDs will no longer be a thing, plus new blocks added and renamed)
    Then will income the complaints when spigot releases 1.13, just like when 1.9 was released.
     
    • Agree Agree x 1
  17. Yea but what happens when the "PVP 1.7 till I die" demands support and it breaks my 1.13 plugin?
     
  18. Legoman99573

    Supporter

    They can fork it for their own use or quit complaining. Simple
    I don't see many 1.7 trolls left here other than lax.
     
    • Agree Agree x 2
    • Like Like x 1
  19. They will come though when servers tell their users to blame Spigot (could happen I guess).
     
  20. Or we create a custom minecraft version of the earliest released version ever and add a multiplayer function.
     

Share This Page