Spigot SurvivalMysteryChests 1.7.9

An effective mystery chests plugin, great for survival servers ! [1.7-1.13]

  1. zeR. submitted a new resource:

    ◆ SurvivalMysteryChests (1.7 & 1.8) ◆ Create unlimited mystery chests for your players ! - → An awesome & very effective mystery chests plugin, great for survival/pvp/faction/... servers !

    Read more about this resource...
     
  2. Can you add command rewards?
    The item settings would only determine the reward's appearance in the chest rolling menu, and actually it would run a config-defined console command
    For example I make a diamond with a name "$100" and put a custom command "eco give {player} 100", then if player opens a chest the item will show a diamond with the name "$100", but when the player win it, they don't receive the diamond but instead the console runs "eco give {player} 100" so the player gets $100
     
  3. i created a free chest and the items didnt load (fresh conf file)
    just shows bedrock :/
     
  4. Do you have errors in the console ? Have you met the YAML format ?
     
  5. it works now the server restarted - so no problems :)
     
  6. ^^
     
  7. can you add command support for rewards to give the reward instead of announce it to the server?
     
  8. uh ? :/
     
  9. Hi! This plugin looks amaaaaaazing, but it won't work on my server, which is a Spigot 1.9 :(
    I did not change anything on the config for the time being, and still the commands aren't working. And it seems I don't even have an error on my console :/
    I hope you have any idea on how to solve this problem :)

    (please excuse me for my bad english, i'm french)
     
  10. Salut, as-tu le message coloré dans la console qui s'affiche lors du démarrage du serveur ? Si oui, quelle version de Spigot précise as-tu, et quels autres plugins as-tu ? :)
     
  11. Ah cool, un français :D
    Alors, le message de la console pour le démarrage:

    [19:04:20] [Server thread/INFO]: This server is running CraftBukkit version git-Spigot-604e046-69e196f (MC: 1.9) (Implementing API version 1.9-R0.1-SNAPSHOT)

    Et les plugins que j'utilise actuellement (c'est un serveur de test, je risque d'en utiliser d'autres sur la version réelle une fois en 1.9):
    [​IMG]
     
  12. Hmm, bizarre, je ne vois pas trop d'où peut venir le problème (décidément :3) ...
     
  13. Bien, je vais essayer avec la dernière version voir si cela change quelque chose... :)
    Merci
     
  14. Normalement, ça doit marcher sans soucis, cela provenait d'un bug avec l'AutoUpdate ;)
     
  15. [​IMG]
    Ca à l'air de marcher :D
    Génial, tu gères! Par ailleurs, dans la description du plugin, au niveau des commandes, tu as mis "/umc create" (etc.), tu devrais modifier en /smc :)
    Enfin, merci pour l'aide fournie extrêmement rapidement!
     
    • Agree Agree x 1