Symlink Problem

Discussion in 'Server & Community Management' started by Al3xPro, Aug 24, 2013.

  1. I tried to use a symlink and I ran into a problem since it won't load/save unless '/mansave force' is typed in every few min. Is there a fix for this?

    Code (Text):
    2013-08-21 15:40:54 [SEVERE] GroupManager - WARNING - Newer Users file found for lobby, but we have local changes!
    2013-08-21 15:40:54 [SEVERE] GroupManager - WARNING - Unable to save unless you issue a '/mansave force'
     
    #1 Al3xPro, Aug 24, 2013
    Last edited: Aug 24, 2013
  2. The Problem is, that saving the file overrides the link, the easiest solution might be, to link to the entry folder instead of the file
     

  3. Is this what you meam?

    Code (Text):
    ln /home/hub/lobby/plugins/GroupManager/worlds/lobby/groups.yml /home/hub/factions/plugins/GroupManager/worlds/world/groups.yml
    ln /home/hub/lobby/plugins/GroupManager/worlds/lobby/groups.yml /home/hub/kitpvp/plugins/GroupManager/worlds/kitpvp/groups.yml
    ln /home/hub/lobby/plugins/GroupManager/worlds/lobby/groups.yml /home/hub/plotme/plugins/GroupManager/worlds/plotme/groups.yml
    ln /home/hub/lobby/plugins/GroupManager/worlds/lobby/groups.yml /home/hub/qs1/plugins/GroupManager/worlds/world/groups.yml
    ln /home/hub/lobby/plugins/GroupManager/worlds/lobby/groups.yml /home/hub/qs2/plugins/GroupManager/worlds/world/groups.yml
    ln /home/hub/lobby/plugins/GroupManager/worlds/lobby/groups.yml /home/hub/skyblock/plugins/GroupManager/worlds/skyblocklobby/groups.yml
    ln /home/hub/lobby/plugins/GroupManager/worlds/lobby/groups.yml /home/hub/thewalls/plugins/GroupManager/worlds/walls/groups.yml
     
    ln /home/hub/lobby/plugins/GroupManager/worlds/lobby/users.yml /home/hub/factions/plugins/GroupManager/worlds/world/users.yml
    ln /home/hub/lobby/plugins/GroupManager/worlds/lobby/users.yml /home/hub/kitpvp/plugins/GroupManager/worlds/kitpvp/users.yml
    ln /home/hub/lobby/plugins/GroupManager/worlds/lobby/users.yml /home/hub/plotme/plugins/GroupManager/worlds/plotme/users.yml
    ln /home/hub/lobby/plugins/GroupManager/worlds/lobby/users.yml /home/hub/qs1/plugins/GroupManager/worlds/world/users.yml
    ln /home/hub/lobby/plugins/GroupManager/worlds/lobby/users.yml /home/hub/qs2/plugins/GroupManager/worlds/world/users.yml
    ln /home/hub/lobby/plugins/GroupManager/worlds/lobby/users.yml /home/hub/skyblock/plugins/GroupManager/worlds/skyblocklobby/users.yml
    ln /home/hub/lobby/plugins/GroupManager/worlds/lobby/users.yml /home/hub/thewalls/plugins/GroupManager/worlds/walls/users.yml
    because I am doing this and I am still having that problem.

    Just I know the files are all linked since you can edit one and it shows on the rest but the problem I am running into is that if one server has a new player (Lobby) then the other servers will give me that error and then will just cut off everyone from there groups. Kind of a big problem. Currently I am just setting buycraft to apply perms across all servers but i would like it to just apply on the lobby and auto to the rest to make it easier for quick changes.
     
  4. This problem has been sorted out. Removed this thread when seen. Thanks.