Tabbing Commands Kicks User

Discussion in 'Spigot Plugin Help' started by Joedon, May 16, 2016.

  1. Hi there on my bungee server, if someone tabs any command, they are kicked. For OPs they can tab commands though. Any ideas?
     
  2. Any other information you could provide? Log, console error, etc.?
     
  3. Are you using chatControl?
     
  4. Sorry about lack of info. Here's the error...
    Code (Text):
    15.05 16:43:00 [Server] INFO jacobbrynt7
    15.05 16:43:00 [Server] INFO ... 12 more
    15.05 16:43:00 [Server] INFO at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:306) ~[custom18.jar:git-Spigot-a1b8bf3-f01861f]
    15.05 16:43:00 [Server] INFO at java.lang.reflect.Method.invoke(Method.java:497) ~[?:1.8.0_66]
    15.05 16:43:00 [Server] INFO at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_66]
    15.05 16:43:00 [Server] INFO at sun.reflect.GeneratedMethodAccessor566.invoke(Unknown Source) ~[?:?]
    15.05 16:43:00 [Server] INFO at kangarko.chatcontrol.listener.PlayerListener.onQuit(PlayerListener.java:95) ~[?:?]
    15.05 16:43:00 [Server] INFO at kangarko.chatcontrol.hooks.HookManager.isLogged(HookManager.java:146) ~[?:?]
    15.05 16:43:00 [Server] INFO at kangarko.chatcontrol.hooks.AuthMeHook.isLogged(HookManager.java:248) ~[?:?]
    15.05 16:43:00 [Server] INFO Caused by: java.lang.NoClassDefFoundError: fr/xephi/authme/api/API
    15.05 16:43:00 [Server] INFO at java.lang.Thread.run(Thread.java:745) [?:1.8.0_66]
    15.05 16:43:00 [Server] INFO at net.minecraft.server.v1_9_R1.MinecraftServer.run(MinecraftServer.java:559) [custom18.jar:git-Spigot-a1b8bf3-f01861f]
    15.05 16:43:00 [Server] INFO at net.minecraft.server.v1_9_R1.MinecraftServer.C(MinecraftServer.java:660) [custom18.jar:git-Spigot-a1b8bf3-f01861f]
    15.05 16:43:00 [Server] INFO at net.minecraft.server.v1_9_R1.DedicatedServer.D(DedicatedServer.java:400) [custom18.jar:git-Spigot-a1b8bf3-f01861f]
    15.05 16:43:00 [Server] INFO at net.minecraft.server.v1_9_R1.MinecraftServer.D(MinecraftServer.java:820) [custom18.jar:git-Spigot-a1b8bf3-f01861f]
    15.05 16:43:00 [Server] INFO at net.minecraft.server.v1_9_R1.ServerConnection.c(ServerConnection.java:175) [custom18.jar:git-Spigot-a1b8bf3-f01861f]
    15.05 16:43:00 [Server] INFO at net.minecraft.server.v1_9_R1.NetworkManager.handleDisconnection(NetworkManager.java:317) [custom18.jar:git-Spigot-a1b8bf3-f01861f]
    15.05 16:43:00 [Server] INFO at net.minecraft.server.v1_9_R1.PlayerConnection.a(PlayerConnection.java:1060) [custom18.jar:git-Spigot-a1b8bf3-f01861f]
    15.05 16:43:00 [Server] INFO at net.minecraft.server.v1_9_R1.PlayerList.disconnect(PlayerList.java:384) [custom18.jar:git-Spigot-a1b8bf3-f01861f]
    15.05 16:43:00 [Server] INFO at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:487) [custom18.jar:git-Spigot-a1b8bf3-f01861f]
    15.05 16:43:00 [Server] INFO at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:502) [custom18.jar:git-Spigot-a1b8bf3-f01861f]
    15.05 16:43:00 [Server] INFO at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62) ~[custom18.jar:git-Spigot-a1b8bf3-f01861f]
    15.05 16:43:00 [Server] INFO at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:310) ~[custom18.jar:git-Spigot-a1b8bf3-f01861f]
    15.05 16:43:00 [Server] INFO org.bukkit.event.EventException
    15.05 16:43:00 [Server] ERROR Could
    Does it just need an update?

    Yes
     
  5. Then you need to check your chatcontrol config since thats the issue. I cant really help you since I am on my phone and should be sleeping xd
     
  6. I disabled everything that had to do with tabbing in the config and it did nothing.
     
  7. Might sound like a silly suggestion, but make sure your bungee is running the latest build. Even if you're still running 1.8.
     
  8. It's an error with a plugin.

    Google it a bit, maybe look through Spigot, and contact @kangarko
     
  9. PS it says to them "The server you were previously on went down..."
     
  10. Uhh, no. That error is due to ChatControl trying to hook into AuthMe and not being able to find the class it's looking for.
    It just happens to appear when the tab error happens as the tab error (bungee level) kicks the player which calls the player quit event in ChatControl.

    Would have though in 5+ years of coding Java, you would have had to read a stack trace or two.

    Have you tried updating bungeecord yet?
     
  11. I didn't read the entire trace, just up-to the chatcontrol bit.
     
    • Funny Funny x 1
  12. I have no idea how to get bungeecord from buildtools right now... it's not downloading (spigot and cb are).
     
  13. There shouldn't be anything wrong with the first link. It's a link to the CI server.

    As the image says, you don't have permission to use TAB. I suggest looking into what bungee/bukkit plugins you have that would stop that.
    If you have PermissionEX, try enabling debug mode on an account that gets that message to see if it's a Bukkit plugin that is stopping it. If so, assign the missing permission to the group/player.
     
  14. The console error has to do with a broken/outdated AuthMe/ChatControl. Make sure you have latest versions of both of them. If it will still persist, PM me with a new stacktract & I will fix it. (Make sure you restarted the server after upgrading, not only reloading.) I am pretty sure that other messages are not involved with CHC.
     
  15. Im going to bump this again. On a new server on my network it's doing the same thing - but with no console errors, just the the server has gone down error. Any ideas?
     
  16. Have you tried uninstalling chat control? Just to verify that's the problem?