Spigot Tamable Foxes [1.14.X-1.18.2] 2.2.4-SNAPSHOT

Ever wanted to tame foxes? Now you can!

  1. Okay im loading
  2. Code (Text):
    [11:42:22 WARN]: java.sql.SQLException: path to 'E:/MCSManager/server/server_core/MCEP2/world/plugins/Tamablefoxes/userFoxAmount.db': 'E:\MCSManager\server\server_core\MCEP2\world' does not exist
    [11:42:22 WARN]:  at org.sqlite.SQLiteConnection.open(SQLiteConnection.java:215)
    [11:42:22 WARN]:  at org.sqlite.SQLiteConnection.<init>(SQLiteConnection.java:61)
    [11:42:22 WARN]:  at org.sqlite.jdbc3.JDBC3Connection.<init>(JDBC3Connection.java:28)
    [11:42:22 WARN]:  at org.sqlite.jdbc4.JDBC4Connection.<init>(JDBC4Connection.java:21)
    [11:42:22 WARN]:  at org.sqlite.JDBC.createConnection(JDBC.java:115)
    [11:42:22 WARN]:  at org.sqlite.JDBC.connect(JDBC.java:90)
    [11:42:22 WARN]:  at java.sql/java.sql.DriverManager.getConnection(DriverManager.java:677)
    [11:42:22 WARN]:  at java.sql/java.sql.DriverManager.getConnection(DriverManager.java:251)
    [11:42:22 WARN]:  at net.seanomik.tamablefoxes.io.sqlite.SQLiteHandler.connect(SQLiteHandler.java:28)
    [11:42:22 WARN]:  at net.seanomik.tamablefoxes.io.sqlite.SQLiteHelper.createTablesIfNotExist(SQLiteHelper.java:37)
    [11:42:22 WARN]:  at net.seanomik.tamablefoxes.TamableFoxes.onLoad(TamableFoxes.java:60)
    [11:42:22 WARN]:  at com.rylinaux.plugman.util.PluginUtil.load(PluginUtil.java:365)
    [11:42:22 WARN]:  at com.rylinaux.plugman.command.LoadCommand.execute(LoadCommand.java:114)
    [11:42:22 WARN]:  at com.rylinaux.plugman.PlugManCommandHandler.onCommand(PlugManCommandHandler.java:95)
    [11:42:22 WARN]:  at org.bukkit.command.PluginCommand.execute(PluginCommand.java:45)
    [11:42:22 WARN]:  at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:159)
    [11:42:22 WARN]:  at org.bukkit.craftbukkit.v1_16_R2.CraftServer.dispatchCommand(CraftServer.java:802)
    [11:42:22 WARN]:  at org.bukkit.craftbukkit.v1_16_R2.CraftServer.dispatchServerCommand(CraftServer.java:764)
    [11:42:22 WARN]:  at net.minecraft.server.v1_16_R2.DedicatedServer.handleCommandQueue(DedicatedServer.java:425)
    [11:42:22 WARN]:  at net.minecraft.server.v1_16_R2.DedicatedServer.b(DedicatedServer.java:392)
    [11:42:22 WARN]:  at net.minecraft.server.v1_16_R2.MinecraftServer.a(MinecraftServer.java:1278)
    [11:42:22 WARN]:  at net.minecraft.server.v1_16_R2.MinecraftServer.w(MinecraftServer.java:1009)
    [11:42:22 WARN]:  at net.minecraft.server.v1_16_R2.MinecraftServer.lambda$a$0(MinecraftServer.java:178)
    [11:42:22 WARN]:  at net.minecraft.server.v1_16_R2.MinecraftServer$$Lambda$3105/0000000000000000.run(Unknown Source)
    [11:42:22 WARN]:  at java.base/java.lang.Thread.run(Thread.java:836)
    [11:42:22 WARN]: Unexpected exception while parsing console command "plugman load TamableFoxes"
    >org.bukkit.command.CommandException: Unhandled exception executing command 'plugman' in plugin PlugMan v2.1.7
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:47) ~[patched_1.16.3.jar:git-Yatopia-"94afff9"]
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:159) ~[patched_1.16.3.jar:git-Yatopia-"94afff9"]
    at org.bukkit.craftbukkit.v1_16_R2.CraftServer.dispatchCommand(CraftServer.java:802) ~[patched_1.16.3.jar:git-Yatopia-"94afff9"]
    at org.bukkit.craftbukkit.v1_16_R2.CraftServer.dispatchServerCommand(CraftServer.java:764) ~[patched_1.16.3.jar:git-Yatopia-"94afff9"]
    at net.minecraft.server.v1_16_R2.DedicatedServer.handleCommandQueue(DedicatedServer.java:425) ~[patched_1.16.3.jar:git-Yatopia-"94afff9"]
    at net.minecraft.server.v1_16_R2.DedicatedServer.b(DedicatedServer.java:392) ~[patched_1.16.3.jar:git-Yatopia-"94afff9"]
    at net.minecraft.server.v1_16_R2.MinecraftServer.a(MinecraftServer.java:1278) ~[patched_1.16.3.jar:git-Yatopia-"94afff9"]
    at net.minecraft.server.v1_16_R2.MinecraftServer.w(MinecraftServer.java:1009) ~[patched_1.16.3.jar:git-Yatopia-"94afff9"]
    at net.minecraft.server.v1_16_R2.MinecraftServer.lambda$a$0(MinecraftServer.java:178) ~[patched_1.16.3.jar:git-Yatopia-"94afff9"]
    at net.minecraft.server.v1_16_R2.MinecraftServer$$Lambda$3105/0000000000000000.run(Unknown Source) ~[?:?]
    at java.lang.Thread.run(Thread.java:836) [?:?]
    >Caused by: java.lang.NullPointerException
    at net.seanomik.tamablefoxes.io.sqlite.SQLiteHelper.createTablesIfNotExist(SQLiteHelper.java:39) ~[?:?]
    at net.seanomik.tamablefoxes.TamableFoxes.onLoad(TamableFoxes.java:60) ~[?:?]
    at com.rylinaux.plugman.util.PluginUtil.load(PluginUtil.java:365) ~[?:?]
    at com.rylinaux.plugman.command.LoadCommand.execute(LoadCommand.java:114) ~[?:?]
    at com.rylinaux.plugman.PlugManCommandHandler.onCommand(PlugManCommandHandler.java:95) ~[?:?]
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:45) ~[patched_1.16.3.jar:git-Yatopia-"94afff9"]
    ... 10 more
    why i still nd a database?
  3. oh i got it im using Multiverse-Core then my all world r in the worlds folder
  4. Can you explain how to tame clearly? I am using 1.16.3 and i'm not sure if i need to hold the chicken, or if its cooked/raw ect..
  5. Code (Text):

    [00:32:25 INFO]: [Tamablefoxes] Loading Tamablefoxes v1.7.9-SNAPSHOT
    [00:32:25 WARN]: [Tamablefoxes] Could not save language.yml to plugins/Tamablefoxes/language.yml because language.yml already exists.
    [00:32:25 WARN]: [Tamablefoxes] Could not save language.yml to plugins/Tamablefoxes/language.yml because language.yml already exists.
    [00:32:25 INFO]: [Tamable Foxes] Registering entity for MC Version v1_16_R2...
    [00:32:25 INFO]: [Tamable Foxes] Replaced fox friend!
    Would it be possible to not echo out the language file stuff, it seems a bit not needed.

    if there's no lang file it's helpful that it says: language file created.., but if there's one, unless there's a reason to report back it might as well not. They show up as a warning but there's no issue actually.
  6. It's been a while since I wrote that code, but iirc it was something to do with what Spigot is doing in the background with the YAML files. Maybe there's a way I could override it, I'll take a look at it.
    • Like Like x 1
  7. It's raw chicken, and you hold it in your hand. Sort of like how you tame a wolf, but instead of holding bones, you hold a raw chicken.
  8. Thank you! Will you be updating this plugin to 1.16.4?
    • Like Like x 1
  9. It was just updated for 1.16.4
  10. Using LuckPerms (Waterfall + Paper) with Vault installed - no errors with proper permissions assigned- yet: [​IMG]
  11. This looks like FUN ..... thanks for the plugin
    [15:38:52] [Server thread/INFO]: This server is running CraftBukkit version git-Spigot-a19903d-bc6a175 (MC: 1.16.4) (Implementing API version 1.16.4-R0.1-SNAPSHOT)

    [15:39:02] [Server thread/INFO]: [HeroElytra] Loading HeroElytra v1.0
    [15:39:02] [Server thread/INFO]: [Tamablefoxes] Loading Tamablefoxes v1.8-SNAPSHOT
    [15:39:02] [Server thread/WARN]: [Tamablefoxes] Could not save language.yml to plugins/Tamablefoxes/language.yml because language.yml already exists.
    [15:39:02] [Server thread/INFO]: [Tamable Foxes] Registering entity for MC Version v1_16_R3...
    >WARNING: An illegal reflective access operation has occurred
    WARNING: Illegal reflective access using Lookup on net.seanomik.tamablefoxes.versions.FieldHelper (file:/home/dadmar/server/Midgard/plugins/TamableFoxes_v1.8-SNAPSHOT.jar) to class java.lang.reflect.Field
    WARNING: Please consider reporting this to the maintainers of net.seanomik.tamablefoxes.versions.FieldHelper
    WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
    WARNING: All illegal access operations will be denied in a future release
    [15:39:02] [Server thread/INFO]: [Tamable Foxes] Replaced tamable fox entity!
    [15:39:02] [Server thread/INFO]: [PlaceholderAPI] Loading PlaceholderAPI v2.10.9
    #154 DaDMaR777, Nov 9, 2020
    Last edited: Nov 12, 2020
  12. That's not an error, it's just a warning.
  13. I'm confused about what you're saying. Are you saying that you are running into that no permission message, or that you aren't?
  14. I am running into a no permissions error regardless of the permissions that are assigned. Worked when I used OP but other than that my players are unable to tame.
  15. Thats weird, I'll try to install luckperms on my test server and see if I run into it.
    • Like Like x 1
  16. fix this warn

    [19:14:36] [Server thread/INFO]: [Tamablefoxes] Loading Tamablefoxes v1.8-SNAPSHOT
    [19:14:36] [Server thread/WARN]: [Tamablefoxes] Could not save language.yml to plugins/Tamablefoxes/language.yml because language.yml already exists.
    [19:14:36] [Server thread/WARN]: [Tamablefoxes] Could not save language.yml to plugins/Tamablefoxes/language.yml because language.yml already exists.
  17. This is a great plugin, but I think you should make it so you can tell how much health your fox has, a faster method of healing them, and giving them a one slot permanent inventory you can open so you can have them keep an item in their inventory without dropping it for any food item.