Spigot Teleport+ [1.7.X - 1.13.X] | Best Plugin for Teleportation ! 5.5e

Recommended plugin for teleportation

  1. I get a similar reponse. I've tried removing the Data.db file.
     
  2. Can you make it so /setspawn is automatically /spawn for everyone and that it makes you look to the direction the tp is set?
     
  3. Unfortunately, I'm getting the SQL errors as well and the plugin is non-functional with 1.13.2.
     
  4. Also getting those errors as reported before (https://paste.ubuntu.com/p/Gf4NJSnG2q/). I won't try deleting the database, because my players' homes etc are in there.

    If you've changed the database structure, a nice gesture would be a warning that we can't use old data in the new versions. Or, even nicer, you could write a converter for older versions. Or, if it's just a bug, you really should prioritise fixing it.
     
  5. [00:26:31 WARN]: org.sqlite.SQLiteException: [SQLITE_ERROR] SQL error or missing database (no such table: Home)
    [00:26:31 WARN]: at org.sqlite.core.DB.newSQLException(DB.java:941)
    [00:26:31 WARN]: at org.sqlite.core.DB.newSQLException(DB.java:953)
    [00:26:31 WARN]: at org.sqlite.core.DB.throwex(DB.java:918)
    [00:26:31 WARN]: at org.sqlite.core.NativeDB.prepare_utf8(Native Method)
    [00:26:31 WARN]: at org.sqlite.core.NativeDB.prepare(NativeDB.java:134)
    [00:26:31 WARN]: at org.sqlite.core.DB.prepare(DB.java:257)
    [00:26:31 WARN]: at org.sqlite.core.CorePreparedStatement.<init>(CorePreparedStatement.java:47)
    [00:26:31 WARN]: at org.sqlite.jdbc3.JDBC3PreparedStatement.<init>(JDBC3PreparedStatement.java:30)
    [00:26:31 WARN]: at org.sqlite.jdbc4.JDBC4PreparedStatement.<init>(JDBC4PreparedStatement.java:19)
    [00:26:31 WARN]: at org.sqlite.jdbc4.JDBC4Connection.prepareStatement(JDBC4Connection.java:35)
    [00:26:31 WARN]: at org.sqlite.jdbc3.JDBC3Connection.prepareStatement(JDBC3Connection.java:241)
    [00:26:31 WARN]: at org.sqlite.jdbc3.JDBC3Connection.prepareStatement(JDBC3Connection.java:205)
    [00:26:31 WARN]: at me.arvin.teleportp.d.b.b(HomeManager.java:54)
    [00:26:31 WARN]: at me.arvin.teleportp.d.b.<init>(HomeManager.java:43)
    [00:26:31 WARN]: at me.arvin.teleportp.d.b.a(HomeManager.java:36)
    [00:26:31 WARN]: at me.arvin.teleportp.a.b.onCommand(HomeCommand.java:29)
    [00:26:31 WARN]: at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44)
    [00:26:31 WARN]: at com.earth2me.essentials.Essentials.onCommandEssentials(Essentials.java:408)
    [00:26:31 WARN]: at com.earth2me.essentials.Essentials.onCommand(Essentials.java:393)
    [00:26:31 WARN]: at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44)
    [00:26:31 WARN]: at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:139)
    [00:26:31 WARN]: at org.bukkit.craftbukkit.v1_13_R2.CraftServer.dispatchCommand(CraftServer.java:702)
    [00:26:31 WARN]: at net.minecraft.server.v1_13_R2.PlayerConnection.handleCommand(PlayerConnection.java:1648)
    [00:26:31 WARN]: at net.minecraft.server.v1_13_R2.PlayerConnection.a(PlayerConnection.java:1483)
    [00:26:31 WARN]: at net.minecraft.server.v1_13_R2.PacketPlayInChat.a(PacketPlayInChat.java:45)
    [00:26:31 WARN]: at net.minecraft.server.v1_13_R2.PacketPlayInChat.a(PacketPlayInChat.java:1)
    [00:26:31 WARN]: at net.minecraft.server.v1_13_R2.PlayerConnectionUtils.a(SourceFile:10)
    [00:26:31 WARN]: at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
    [00:26:31 WARN]: at java.util.concurrent.FutureTask.run(FutureTask.java:266)
    [00:26:31 WARN]: at net.minecraft.server.v1_13_R2.SystemUtils.a(SourceFile:199)
    [00:26:31 WARN]: at net.minecraft.server.v1_13_R2.MinecraftServer.b(MinecraftServer.java:900)
    [00:26:31 WARN]: at net.minecraft.server.v1_13_R2.DedicatedServer.b(DedicatedServer.java:417)
    [00:26:31 WARN]: at net.minecraft.server.v1_13_R2.MinecraftServer.a(MinecraftServer.java:835)
    [00:26:31 WARN]: at net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:733)
    [00:26:31 WARN]: at java.lang.Thread.run(Thread.java:748)
     
  6. Getting a SQL bug and it's not saving any warps after I restart the server. I attached the error I get, but its similar or exactly the same as the error others are getting.
     

    Attached Files:

  7. Hi guys,
    I need your help. I added the permission ''teleport.rtp'' for players. When players type /rtp they got ''You don't have a permission teleport.rtp.rtp''. After also added permission ''teleport.rtp.rtp'' players can edit in GUI as create, delete or change random teleports.
    Please help.
     
  8. I deleted all data files related to Teleport+, brought up server. What I'm observing:
    1) I appear to be able to create homes now, but when I do, more exceptions are thrown at the console. More exceptions show up when I use the homes.
    2) Warps and spawn are not saved, though the GUI says they are being added successfully. When you attempt to create warps/spawn, exceptions are thrown.

    I've attached logs collected from the server startup (just related to loading tp+)
     

    Attached Files:

  9. Is this supposed to work with 1.3.2? It doesn't.
     
  10. ehh.. I really like that plugin but I would like to disable rtp cuz its blocking other rtp plugin... I want players to teleport randomly to survival world, but this plugin is not good for rtp.. so can I somehow disable that???
     
  11. I reverse-engineered the Plugin and found the mistake in v5.5.d. I emailed @ArvinCiu about it, but for informational purpose, here's what causes the error:

    When the plugin starts, it copies all Database tables to a backup table, deletes the original table and renames ther backup table back to it's original name. I suppose this is done to provide at least limited backwards compatibility (however only minimal changes can be "repaired" this way).

    In Database.java (around line 41, however my line nubmers are likely off due to decompiling): The SQL Statement "ALTER TABLE ... RENAME TO ..." is executed. It ends up being run using a prepared statement and java.sql.PreparedStatement.executeUpdate (in SQLUtil.java, around line 20). However this function fails if the query returns any result set (it's in the documentation, yo!). In this case, "ALTER TABLE" actually returns the number of changed tables for SQLite (because internally it is an UPDATE-statement on system tables), which causes an exception.

    As a result, the tables got copied to backups, the original tables are deleted, but renaming them back to their original names fails. As a consequence, the tables are not available afterwards, causing all the other Exceptions.
     
    #472 Sneh0nja, Nov 28, 2018
    Last edited: Nov 28, 2018
  12. Suggestion to add money and/or xp requirements in order to teleport and if "/tpdeny" is used by the other player, then the original caster gets a refund

    EDIT - Nvm just realised it's already a thing
     
    #474 Alter-Ego, Dec 17, 2018
    Last edited: Dec 29, 2018
  13. Seems to be mostly working now. I still get an Exception when using /seehome though (not that that command was particularly important). It's a NullPointerException somwehre in ArvinLib:

    Code (Text):
    Caused by: java.lang.NullPointerException
            at me.arvin.lib.util.TextUtil.placeholder(TextUtil.java:111)
            at me.arvin.teleportp.a.b.onCommand(HomeCommand.java:173)
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44)
     
  14. I know its small, but can you add a prefix option for the database part of the plugin? I have a db with many other plugins and its hard to keep track of whats what when I cant prefix the db tables <3
     
  15. Does this work alongside essentials commands or do they have to replace essentials commands?
     
  16. Suggestion to make it so that its compatible with towny in the sense that if a player who isn't a part of your town is close by then the teleport delay will take effect (make seperate delay for players) and also to make an additional option to make it so that you can't teleport at all when players who aren't a part of your town are nearby

    I also suggest adding an option that charges EXP to teleport instead of money
     
  17. FOUND A BUG! Go right click on a chicken with arvin lib in your plugins folder lol right clicking on chickens makes them lay eggs as much as you want!
     
  18. Did you fix the bug with pets mentioned in this thread in August?
    My users are getting duplicate pets and also apparently invisible duplicate horses...
    Is there a way to prevent pets from teleporting entirely?

    I am using the latest version and Minecraft 1.13.2.