Teleportation Lag

Discussion in 'Spigot Help' started by 6010fd12, Jun 6, 2015.

  1. Machine Specs:
    OS: Windows Server 2012 R2
    CPU: Xeon E3-1240 V3
    RAM: 32 GB
    STORAGE: 64GB SSD + 500GB HDD (For Backups)



    Lag/Delay Discription:
    Whenever a player teleports, in any form rather its from server to server or within the same server regardless of command (ex. /warp, /tp, /tpo, /tpa ...) there seems to be a delay till the player can perform an action or even chat.

    Ex. After using a form of warp/teleport and i have appeared in the new location there is a 10-15 second period where anything i type into chat or command or even try to interact with (ex. chests, doors, etc...) do not get issued nor interact with me. After that 10-15 second delay every all chat appears in one shot, and any interaction i performed during the delay are fast forwarded on screen. Even if you try to move during this time, the player will just rubber-band back to the warp-in location till the delay is over.

    IMPORTANT: This is not a network issue because in the time that a player teleports and is experiencing this lag, if they type any message in chat, other players can see it instantly and if I look in console it appears instantly but the client that is still in the lag/teleport state can't see what they wrote until their lag is done (10-15 seconds)

    This delay/lag is only experienced by that one player whom just warped and no other player seems to be effected or notice it.

    Any suggestions? If you want to experience this bug for your self please join my server.
    Server ip: Thewolfpack.no-ip.org
    I am so confused on what the problem might be.
     
  2. Move your OS to Ubuntu server it will save a lot of lag and ram and cpu PM me if you need help set it up in any way.