Spigot TerrainControl 2.8.1

Advanced custom world generator

  1. TerrainControl submitted a new resource:

    TerrainControl - Advanced custom world generator

    Read more about this resource...
     
    • Like Like x 2
  2. Glad to see this on spigot! :D
     
  3. Here we are!

    If you have any questions, please ask them on the forums at forum.mctcp.com. Posting for help in this thread is possible, but not recommend: as discussions are not threaded they tend to get chaotic (at least that was our experience on BukkitDev). It's also difficult for other users to search for previously solved problems. So please use the forums instead! You can log in there with your Google or Github account there.
     
  4. It dont work for me :( my servers are running CraftBukkit version git-Spigot-1.7.9-R0.2-207-g03373bb (MC: 1.7.10) (Implementing API version 1.7.10-R0.1-SNAPSHOT)
     
  5. Prob for Ver 1.8...Works fine for me...Use an older ver.
     
  6. What Mctyler said, use an old version. The changelog link on top of the page goes to a page with all old versions, each one stating the Minecraft version they're made for.
     
    • Agree Agree x 1
  7. Nope cant even run it on 1.8 spigot.... fix it please?
     
  8. This screenshot mentions absolutely nothing about TerrainControl...It actually looks like your world is corrupt. Follow the advice it gives you in the error.
     
    • Agree Agree x 1
  9. by me it don't create a config.yml and i can't make a new world it gif errors (multivers)
     
    #10 the_master_98, Dec 10, 2014
    Last edited: Dec 10, 2014
  10. I think your a little in over your head....you gotta a lot of reading to do...It all works fine if set up properly.
     
  11. ... I Ran this command /mv create test normal -g TerrainControl. And then it give me that error for the world test which was made by this plugin? So its the plugin not my world?
     
  12. "Test" is the name that Multiverse uses to test if a plugin has a world generator. Creating an actual world named "test" won't work, TC won't create any config files... The plugin should have notified you about this elsewhere in the console.

    TC doesn't have a config.yml, we use a lot of other files in a directory structure. See the installation instructions, linked from the How to use section. Make absolutely sure that the right version is installed. If you still have errors, please post your logs/latest.log file somewhere.

    To everyone wanting to have their question answered in this thread:

    Although I'm not ignoring questions here, I still think that the forums
    (http://forum.mctcp.com, linked from the How to use section) is a better place for questions like this. It's much better organized: each question can have its own thread. Also, anyone else having the same question will have a difficult time finding the answer in this thread. On a dedicated forum the question is the title of the page, so Google can easily find it.
     
    • Agree Agree x 1
  13. These guys are clueless....I gave up on helping them until they read a little bit...
     
    • Agree Agree x 1
  14. Glad to hear that you guys moved to a better forum website, Kudos to you!
     
  15. Why don't you add some default custom biomes? Too long and complicated to create our own.
     
  16. That's why there is a Download premade worlds, biomes and objects link on the "How to use" section. The biomes are just not bundled with TC.
     
    • Like Like x 1
    • Informative Informative x 1
  17. Thanks for informing me, last time I tried this plugin the premade worlds weren't there.
     
    • Like Like x 1
  18. I am carious to which download link I am supposed to use for latest 1.8 version, on the Jenkins site the latest Bukkit version is 557KB while this version on spigot is 558KB, which is the correct one for latest 1.8 version?
     
  19. The build on Spigot should work fine. The builds on the build server are newer and more experimental. If you have found a bug in the build on Spigot, you should try the build on the build server to check if the build is still there. If the build on Spigot works fine for you, you can just use that.