The Plugin 7.0

Discussion in 'Spigot Plugin Help' started by BrettPlayMC, May 10, 2016.

  1. I was starting up my server and I got an error while loading one of my plugins. Can anyone help me? :p
    Error:
    Code (Text):
    java.lang.NoClassDefFoundError: net/minecraft/util/org/apache/commons/io/FileUtils
        at com.mrlolethan.nexgenkoths.P.initConfiguration(P.java:109) ~[?:?]
        at com.mrlolethan.nexgenkoths.P.onEnable(P.java:52) ~[?:?]
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) ~[spigot_1.8.8_latest.jar:git-Spigot-e4d4710-e1ebe52]
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:340) [spigot_1.8.8_latest.jar:git-Spigot-e4d4710-e1ebe52]
        at us.Myles.PWP.TransparentListeners.PerWorldPluginLoader.enablePlugin(PerWorldPluginLoader.java:145) [PerServerPlugins.jar:?]
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot_1.8.8_latest.jar:git-Spigot-e4d4710-e1ebe52]
        at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugin(CraftServer.java:357) [spigot_1.8.8_latest.jar:git-Spigot-e4d4710-e1ebe52]
        at org.bukkit.craftbukkit.v1_8_R3.CraftServer.enablePlugins(CraftServer.java:317) [spigot_1.8.8_latest.jar:git-Spigot-e4d4710-e1ebe52]
        at net.minecraft.server.v1_8_R3.MinecraftServer.s(MinecraftServer.java:414) [spigot_1.8.8_latest.jar:git-Spigot-e4d4710-e1ebe52]
        at net.minecraft.server.v1_8_R3.MinecraftServer.k(MinecraftServer.java:378) [spigot_1.8.8_latest.jar:git-Spigot-e4d4710-e1ebe52]
        at net.minecraft.server.v1_8_R3.MinecraftServer.a(MinecraftServer.java:333) [spigot_1.8.8_latest.jar:git-Spigot-e4d4710-e1ebe52]
        at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:263) [spigot_1.8.8_latest.jar:git-Spigot-e4d4710-e1ebe52]
        at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525) [spigot_1.8.8_latest.jar:git-Spigot-e4d4710-e1ebe52]
        at java.lang.Thread.run(Unknown Source) [?:1.8.0_77]
    Caused by: java.lang.ClassNotFoundException: net.minecraft.util.org.apache.commons.io.FileUtils
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:91) ~[spigot_1.8.8_latest.jar:git-Spigot-e4d4710-e1ebe52]
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot_1.8.8_latest.jar:git-Spigot-e4d4710-e1ebe52]
        at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_77]
        at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_77]
        ... 14 more
     
  2. Send that log to the author of your plugin along with the server version. It seems that the plugin is not compatible with spigot 1.8, since it uses an old import.

    Tell the developer to replace:
    Code (Text):
    import net.minecraft.util.org.apache.commons.io.FileUtils;
    with:
    Code (Text):
    import org.apache.commons.io.FileUtils;
     
  3. The last update was 2014 :(
    R: NexGen KoTHs v0.8 for CB 1.7.9-R0.2 Dec 28, 2014
    http://dev.bukkit.org/bukkit-plugins/nexgen-koths/
     
  4. Ok. :)