The type com.avaje.ebean.EbeanServer cannot be resolved. It is indirectly referenced from required .

Discussion in 'Spigot Plugin Development' started by Grickoo, Aug 8, 2018.

  1. Hello, yesterday i downloaded a plugin source from github (Bladian'sUHC/FazonGG's UHC Plugin). I add all depends and it's giving me a one error The type com.avaje.ebean.EbeanServer cannot be resolved. It is indirectly referenced from required .class files.
    Error is on this
    Code (Text):
    package me.bladian.uhc;
    Here it is a code below that line: http://prntscr.com/kg1xx5
    Here is my build path: http://prntscr.com/kg1x43. If you need something alse to see tell me and i'll post it.
     
  2. Must be an older plugin. Spigot used to come bundled with the Ebean framework for easy database access, but that was scratched around version 1.9 or so, I think. You either have to modify the pom.xml and some plugin code to provide the EbeanServer yourself, or rewrite the parts of the plugin which try to utilize Ebean.