This happens whenever the server starts - help?

Discussion in 'Spigot Help' started by sxr, Jun 12, 2015.

  1. sxr

    sxr

    Please note that I'm actually not using CraftBukkit - I just name the jar that for compatibility with the host.

    Failed to start the minecraft server
    java.lang.NullPointerException
    at com.google.common.base.Preconditions.checkNotNull(Preconditions.java:213) ~[craftbukkit.jar:git-Spigot-6a6b839-b0e81a4]
    at com.google.common.collect.Lists$ReverseList.<init>(Lists.java:767) ~[craftbukkit.jar:git-Spigot-6a6b839-b0e81a4]
    at com.google.common.collect.Lists.reverse(Lists.java:759) ~[craftbukkit.jar:git-Spigot-6a6b839-b0e81a4]

    I use McMyAdmin. Any ideas as to why this is?
     
  2. Can you post the full error, please?
     
  3. sxr

    sxr

    Didn't realize that McMyAdmin's console didn't log the full error.
    Here it is:

    [00:42:41] [main/FATAL]: Failed to start the minecraft server
    java.lang.NullPointerException
    at com.google.common.base.Preconditions.checkNotNull(Preconditions.java:213) ~[craftbukkit.jar:git-Spigot-6a6b839-b0e81a4]
    at com.google.common.collect.Lists$ReverseList.<init>(Lists.java:767) ~[craftbukkit.jar:git-Spigot-6a6b839-b0e81a4]
    at com.google.common.collect.Lists.reverse(Lists.java:759) ~[craftbukkit.jar:git-Spigot-6a6b839-b0e81a4]
    at net.minecraft.server.v1_8_R3.UserCache.b(UserCache.java:191) ~[craftbukkit.jar:git-Spigot-6a6b839-b0e81a4]
    at net.minecraft.server.v1_8_R3.UserCache.<init>(UserCache.java:70) ~[craftbukkit.jar:git-Spigot-6a6b839-b0e81a4]
    at net.minecraft.server.v1_8_R3.MinecraftServer.<init>(MinecraftServer.java:136) ~[craftbukkit.jar:git-Spigot-6a6b839-b0e81a4]
    at net.minecraft.server.v1_8_R3.DedicatedServer.<init>(DedicatedServer.java:43) ~[craftbukkit.jar:git-Spigot-6a6b839-b0e81a4]
    at net.minecraft.server.v1_8_R3.MinecraftServer.main(MinecraftServer.java:926) [craftbukkit.jar:git-Spigot-6a6b839-b0e81a4]
    at org.bukkit.craftbukkit.Main.main(Main.java:185) [craftbukkit.jar:git-Spigot-6a6b839-b0e81a4]
     
  4. Try to recompile the jar again
     
  5. sxr

    sxr

    Done that... multiple times...
     
  6. Let me run the latest version of BuildTools, and I'll report if I'm having the same problem or not.
     
    • Agree Agree x 1
  7. sxr

    sxr

    The thing is, it happens regardless of the Spigot version I use.
     
  8. Can you run the server on your home computer? See if you still get the same error. If you can run it on your computer fine then it might be a problem with the host.
     
    • Agree Agree x 1
  9. sxr

    sxr

    Interestingly, it does run on my home computer just fine. I'll investigate this further.
     
  10. They might have some weird java arguments that are trying to get the server to run in a different way. Speak to your host :)
     
  11. sxr

    sxr

    I host my server on a VPS, not a dedicated Minecraft host. That is not the case.
     
  12. Can you run the server without McMyAdmin?
     
  13. sxr

    sxr

    I can, and I don't get this error. I'll begin to troubleshoot with McMyAdmin.
     
  14. Play around with the settings in McMyAdmin. Might be something strange in the config. :)
     
  15. sxr

    sxr

    The weird part about this is it just happened after a normal bi-hourly restart. Nothing changed.
     
  16. Hmm, that does make it more interesting. Maybe try to restart your VPS to let McMyAdmin reboot
     
  17. Tux

    Tux

    Deleting usercache.json might help. Not sure.
     
    • Useful Useful x 9
    • Winner Winner x 4
    • Like Like x 3
    • Agree Agree x 1
  18. sxr

    sxr

    Aha, that did it. Dunno why that would be, but it did it. Thank you. :)
     
  19. Weird. Might be a player in corrupt chunk? Glad its fixed :D
     
  20. You might have to save the plugins folder and your world(s) folder(s) and do it again, or maybe its how much RAM you put into it. Sometimes you put too much RAM then you have on your computer. If that is the problem, there are many FREE ways to add more RAM without downloading.