Spigot TimeControl [1.13.X - 1.14.X] [FREE] 3.1.0

Control the length of day and night separately for each world!

  1. Alex_qp submitted a new resource:

    TimeControl - Control the length of day and night (separately).

    Read more about this resource...
  2. Alex_qp updated TimeControl with a new update entry:

    Major update! Full support for multiple worlds, Commands, Permissions!

    Read the rest of this update entry...
  3. Alex_qp updated TimeControl with a new update entry:

    Bugfix and debug command

    Read the rest of this update entry...
  4. Alex_qp updated TimeControl with a new update entry:

    Update to MC v1.13, New Features, Small Bugfix

    Read the rest of this update entry...
  5. Alex_qp updated TimeControl [1.13.X] with a new update entry:

    Critical Bugfix

    Read the rest of this update entry...
    • Informative Informative x 1
    • Like Like x 1
  6. After using v2.01 (last version that supports 1.12 and wasn't removed from the download list), either I'm missing something involving configuration, or the plugin just doesn't work properly. It set all my worlds to 6am and changed the gamerule to false, but it won't actually do anything in the way of actually moving their time..
  7. Granted, if it worked, it'd be perfect for the kind of server I've been trying to make, but it seems to be a little... buggy, to say the least...
  8. @bigredguy2 Please send me your configurations as well as the output of /timecontrol debug as private message.
  9. I didn't even configure anything yet, but it selected my main world as well as its nether and end at first. I was searching through old files for some "Lore" stuff I thought I had saved (apparently I don't have it anymore) that happened to include day and night cycles for each planet/world - would fit this plugin perfectly - so eventually I went back and cleared all the text from it to attempt to get it to stop messing with my main world. After that it just did so with every last world in the server, and I had to go through and re-enable the gamerule after disabling the plugin in 80 world files... Was not fun. Regardless, I hadn't actually configured anything, so it's the default of v2.01 (since I'm running 1.12.2 still)
  10. Alex_qp updated TimeControl [1.13.X] with a new update entry:

    Special Version for MC 1.12.X

    Read the rest of this update entry...
  11. Hi.
    Saw this error when a normal player executed /tc. He has no permissions whatsoever.
    Code (Text):
    [05:25:56 INFO]: player123 issued server command: /tc
    [05:25:56 ERROR]: null
    org.bukkit.command.CommandException: Cannot execute command 'tc' in plugin TimeControl v2.06 - plugin is disabled.
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:36) ~[patched_1.13.2.jar:git-Paper-463]
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:149) ~[patched_1.13.2.jar:git-Paper-463]
    at org.bukkit.craftbukkit.v1_13_R2.CraftServer.dispatchCommand(CraftServer.java:732) ~[patched_1.13.2.jar:git-Paper-463]
    at net.minecraft.server.v1_13_R2.PlayerConnection.handleCommand(PlayerConnection.java:1799) ~[patched_1.13.2.jar:git-Paper-463]
    at net.minecraft.server.v1_13_R2.PlayerConnection.a(PlayerConnection.java:1602) ~[patched_1.13.2.jar:git-Paper-463]
    at net.minecraft.server.v1_13_R2.PacketPlayInChat.a(PacketPlayInChat.java:45) ~[patched_1.13.2.jar:git-Paper-463]
    at net.minecraft.server.v1_13_R2.PacketPlayInChat.a(PacketPlayInChat.java:5) ~[patched_1.13.2.jar:git-Paper-463]
    at net.minecraft.server.v1_13_R2.PlayerConnectionUtils.lambda$ensureMainThread$0(PlayerConnectionUtils.java:12) ~[patched_1.13.2.jar:git-Paper-463]
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) ~[?:1.8.0_181]
    at java.util.concurrent.FutureTask.run(FutureTask.java:266) ~[?:1.8.0_181]
    at net.minecraft.server.v1_13_R2.SystemUtils.a(SystemUtils.java:109) ~[patched_1.13.2.jar:git-Paper-463]
    at net.minecraft.server.v1_13_R2.MinecraftServer.b(MinecraftServer.java:1016) ~[patched_1.13.2.jar:git-Paper-463]
    at net.minecraft.server.v1_13_R2.DedicatedServer.b(DedicatedServer.java:439) ~[patched_1.13.2.jar:git-Paper-463]
    at net.minecraft.server.v1_13_R2.MinecraftServer.a(MinecraftServer.java:943) ~[patched_1.13.2.jar:git-Paper-463]
    at net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:841) ~[patched_1.13.2.jar:git-Paper-463]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_181]
    A player without permissions should not see the command in the tab-completer at all. Is it possible that you can hide this? I've heard it is done by stating the permissions in the plugin.yml. But I dont' have any java knowledge, so don't get me wrong ;-)
  12. Hey @endercreeper First of all please make sure to always update to the latest version if possible (you are 1 version behind)
    Second: It is intentional behavior that every player can perform /timecontrol alias /tc because I want everybody to be able to see the credits. So for that reason I have to deny your feature request unfortunately.

    And finally to your bug report: As stated in the error message the plugin was disabled at the time the command was executed. As far as no other plugin was involved TimeControl will disable itself if critical logical bugs are created which make it unnecessary for the plugin to be enabled in the first place (i. e. no world is enabled due to disabling options in the config)

    So you might want to check your configurations.
  13. I get the feeling that "world" should not be disabled
    Code (YAML):
     - world
    Thanks for the heads up on the 2.07 update. Missed that one.
  14. I am not sure if I understand you right but of course if you have no other world enabled the plugin will disable itself. So i. e. if you do not have a plugin for multiple worlds and just disabled world the plugin will disable itself because by default world_nether and world_the_end are disabled by world-environments options.