Timed Out using Public IP

Discussion in 'Spigot Help' started by setic, Sep 12, 2019 at 12:44 AM.

  1. I'm pretty sure I've done everything correct but it still doesn't work. So this is what I did I've made sure if the server works and it works when I connect through my IPv4 address. Then I port fowarded on my Netgear router which is shown in the screenshot attached. Then I made inbound/outbound rules in windows firewall doing both TCP and UDP in inbound and outbound using the port 25565. I had Norton but I uninstalled it so the only firewall I have is windows firewall. I've searched far and wide and scoured through the internet looking for a solution but none of them worked. My cable connection thing is: Internet > Modem > Netgear Nighthawk X6 R8000 > My PC. Also I've tested my port through canyouseeme.org and had the server up but it still didn't work. So idk what to really do, I'm pretty sad
     

    Attached Files:

    #1 setic, Sep 12, 2019 at 12:44 AM
    Last edited: Sep 12, 2019 at 11:59 AM
  2. Strahan

    Benefactor

    That's normal. Not a lot of home routers support NAT reflection. What that means is the ability to access NAT'd services from within the NAT'd network. You need to use the internal IP for playing on the server, everyone else outside will use the public IP.

    PS - IPv4 does not have anything to do with public vs private. It's just a format of IP. Your public IP is IPv4 as well :)
     
  3. I recommend reading over the Forum Etiquette: Blanking Threads thread. In the future, someone might need to ask the same question, and google looking for answers, blanking a thread out to "nvm" serves no purpose.
     
  4. I said it in another thread because I thought it was in the wrong section of the forums so I blanked it out here :/
     
  5. umm soo... my friends still can't connect to the public ip. Is there another thing I have to look over to fix?
     
  6. Strahan

    Benefactor

    Ah I misread, I thought you said the test on canyouseeme worked. Hmmm. Is your private network address static? If not, be sure it didn't change. Is your modem just a basic pass through or does it have its own firewall? It could even be the ISP blocking ports.
     
  7. My private network address is static. And I’m not sure if my modem has a firewall but I’m pretty sure it’s just a basic pass through