Timings - Problem with chunks and...

Discussion in 'Spigot Help' started by KiroxTV, Dec 13, 2019.

  1. Of course I read this post carefully. On my previous server, everything was fine, but the problem arose. I made a worldborder map and wbfill, what else can I do?
     
  2. Check the guide changelog, it had important changes last months
     
  3. I did it of course, eh. So the problem in my server is with the entities and the chunks?
     
  4. Can someone help me, please?
     
  5. That's not an error, but the server telling you it has not responded for 10 seconds. In that case it has not responded because you ran the /save-all command which is known in 1.14 to take a long time to complete.

    You only have one CPU core, which is not ideal. The server runs many tasks asynchronously including (because you are using Paper) chunk loading. Try disabling the async-chunks setting in the paper.yml file of your server directory. With only one CPU core it may be harming you more than it's helping.

    You'd be better off going through Paper's support channels, like Esmorall said. You might want to provide a longer timings report though, there's not much that can be seen from a 5 minute report.
     
  6. Look, that's the problem - out of memory
    https://hastebin.com/zonecibidu.rb - i did now the async-chunks to false, i'll check now, but the problem is <--

    So what's the plugin for autosaving without having any lags? I heard about it but i don't remember the name of plugin
     
    #9 KiroxTV, Dec 14, 2019
    Last edited: Dec 14, 2019
  7. I think that you are starving your server !
    You have a 4GB memory server, yet you allocate the full 4GB of memory to your application.
    What has the Java OS been left with? > nothing !
    You need to allow at least 256MB for Java to work.
    Therefore your -Xms and -Xmx should not be given more than 4GB - 256MB.

    I would set them at 3584M to allow Java to use up to 512M