To all Developers who dropped 1.8 support (or plan to), Here is a message for you.

Discussion in 'Spigot Discussion' started by Nubba, Feb 13, 2020.

Thread Status:
Not open for further replies.
  1. Andre_601

    Supporter

    There aren't any valid reasons here to NOT update your server to a 1.9+ version.
    The most common "reasons" about why sticking with 1.8 are often either "The 1.9 PvP sucks!" or "Other servers do that too!"

    I mean even the author of this thread gave this response:
    First of all: Stop taking big servers as role models or reasons for your server.
    They are big because they are popular (obviously).
    Just because Hypixel, HiveMC or whatever other servers you mention has 1.8 as basic server version, doesn't mean it will work with your 1.8 Spigot server.
    First is the server most likely custom made, so that the devs can easily integrate new game modes, systems, etc.
    For example, does Hypixel have a custom save-system for the worlds (The SRF-system) which plugins like SlimeWorldManager add to Spigot.

    We should stop here to do something just because others do it, or else your server will be yet another "SkyBlock, Factions and Creative Server with Prison setup". You don't wanna know how many of those servers I saw so far....

    There are multiple reasons for devs to use newer API versions and drop support for older ones.

    The most important one is, that the API got major (often breaking) changes which make backwards-compatibility nearly impossible without the usage of things like Reflection, which isn't an easy task for beginner-devs.
    1.9 brought some major changes and 1.13 was a huge breakpoint for plugins using sound-, entity-, block- and item-names/ids, as those got huge changes then.

    If you are aware that 1.8 is 5 years old AND has limitations to 1.9, why trying to find arguments to convince us to still support it?
    Like I said at the beginning are there no valid reasons here to justify using and supporting an old version.
    People stick with it because others do that too and if we don't break this stupid behaviour, then we will still be here at 1.8 even when 1.20 would be out.

    Another thing I love to do is comparing updating Spigot with updating your PC or Smartphone.
    Imagine you have a nice Android or Windows version and you receive the notification that there's a new version, which fixes bugs, glitches and most importantly: security vulnerabilities.
    You get info from friends and other people that the update, however, changed some stuff at the UI, behaviour, etc. of the OS. Would you keep the old version and risk the security vulnerabilities, or would you update, fix those issues and adapt to the changes?
    If you stick with not updating your OS, then I wish the best of luck to not get any attacks on your PC or Smartphone and with receiving support for this outdated OS.

    A server can (and maybe should) be treated as an OS, meaning you should update it to fix all kinds of issues.
    Only god knows what for exploits 1.8 has that were fixed in later updates.
     
    • Winner Winner x 4
    • Agree Agree x 2
    • Funny Funny x 1
    • Optimistic Optimistic x 1
  2. They are using code base That's exactly the thing I was talking about. They server owners won't do it
    This is what it comes down to.

    Even smaller factions server with 100-150 players are making $150k a year. If they upgrade to 1.9+ they start losing players and revenue, which puts them in the position of having to stay on 1.8 or sell their $500k home. It's a business decision, it doesn't make sense to give up your revenue when the people paying you don't want to play on newer versions.
     
  3. Andre_601

    Supporter

    At one point we have to force people to move on.
    They stick to a 5 year old version. 5 YEARS!

    Like I said do people stick with 1.8 because others do. We need to break this to finally move on to a new chapter and the best (and easiest) way is for devs to stop supporting 1.8.
    I applause to every dev that decides to drop 1.8 support and only supports the newer versions. You guys make the right decision, no matter what everyone says.
     
    • Winner Winner x 3
    • Agree Agree x 2
  4. If they have such revenue, then they can pay for a private version of a plugin that supports whatever server version they use.
    They shouldn't bug public plugin developers then.
     
    • Agree Agree x 2
    • Winner Winner x 1
  5. Here's a valid reason, excerpted from another thread:

    Somehow, my server has become popular with Mineplex 'Clans' players. They use my server to prototype their bases, which can be quite elaborate. These Clans players are all on 1.8.8. I think the Clans players found my server when I was one of the very few 1.8.8 Creative servers in the United States, and the large 101x101 plots provide a lot of room to build. I also allow WorldEdit and Schematica 'Printer', both of which they use frequently. Since Clans is still a 1.8.8 game, they want a server which supports 1.8.8 so they don't have to switch game versions.

    Having said that, the server is 1.15.2 and I use the Via suite to provide 1.8.8 compatability.

    Only god knows what for exploits 1.15.2 and 1.16 have that have not been fixed at all.
     
    • Like Like x 1
  6. Andre_601

    Supporter

    I still don't see a reason to use 1.8 here.
    You kinda contradict yourself here as your reason shows the user using 1.15.2 with 1.8 compatibility, which isn't the same as USING 1.8 in that regard. They just give support for it through other methods like plugins.
     
  7. That was the point I made in my first post. developers have no reason to keep developing for 1.8, because the server owners making all the money are not sharing the revenue through donations or even plugin purchases.

    I'm not trying to argue that devs should keep developing for 1.8. I'm arguing that if server owners running these versions want support for 1.8, then they need to bring out their wallet and pay for some dev support.
     
  8. Strahan

    Benefactor

    Easy to say when it isn't your $150k+ annual income that will be at risk, heh. If someone is making that much with it, I don't blame them for not wanting to rock the boat.
     
    • Like Like x 1
  9. you read that backwards, the user is using 1.8 and his server is 1.15, however I don't see the point of his post because nothing to do with providing plugin support for 1.8. (I think he may be confused also, considering all his plugins are running 1.15+ and only via is allowing 1.8 to connect)
     
  10. At the end of the day, unless literally everyone moves on from 1.8 at the same thing, we won't see it happen anytime soon. maybe more people will move after the new combat update, but it's arguable to create people to be stuck on TWO versions forever instead of one. If servers like Mineplex, Hive, CubeCraft, Mine Superior, or any other large ones don't ever update, neither will the players. It's a force thing.

    As for my stance, I really don't see the value in avoiding updates as some things like the PvP stuff can be changed to normal, and people just refuse to accept the fact it can sort of be like 1.8, but also spur out other BS, false claims about new versions. I am a person who enjoys to keep innovating my game with new content, so that is what I do- keep updating. At this point, I try not to play 1.8 servers, especially if it's a PvP gamemode, as I don't have that version installed and don't plan on downloading it- only keeping 1.12.2 and 1.15.2 as these are the "acceptable" versions (in my opinion).
     
    • Like Like x 1
  11. electronicboy

    IRC Staff

    All the more reason that people should actually support devs instead of feeling entitled to demand that people support these 5 year old versions for nothing in return.
     
    • Agree Agree x 2
  12. I personally still use 1.8 for all of my servers. I was using 1.8 plugins until I started realizing that most plugins stopped supporting it. I started just custom coding everything myself.

    Eventually, people are going to have to realize that not everything is going to support 1.8. There is just too much of a hassle to go through to ensure that some servers are going to be happy because you still support 1.8.

    It really comes down to 2 things; either 1, you upgrade to a later version with whatever risk comes with it for the sake of having better plugins, or you stay on 1.8 and custom code everything. Don't try to rely on developers to go through the hassle of supporting a 5 year old version. If you still want them to support 1.8, give them a reason to want to go through all of the work to support it, like donating.

    If you want to stay on 1.8 and don't care to support the developers to give them a reason to make their plugins compatible with it, either hire your own developers to custom code everything, or whip up Eclipse or IntelliJ and do it yourself.

    Bottom line, don't expect developers to go through the hassle of supporting an outdated system. If you want to use 1.8 still, code it yourself. Simple as that.
     
    • Like Like x 2
    • Agree Agree x 1
  13. Hypixel isn't at base 1.8, their server software is at base 1.7.10, heavily modified and features added by themselves (you don't believe me? there are still bugs in hypixel from 1.7.10 that got patched in 1.8, you can test if you want). Also the fact there is a whole dev team to fix every bug or something other, for which they get paid. As someone said in page #1 on this thread, run Windows 7 if you want, but don't bother Microsoft to give you updates for free if they have abandoned the version.

    Aagh, the playerbase, sure. 1.8 playerbase is toxic. But if you explain them the point from server owner or give them a point from developer, if the person who present that data to isn't as toxic as chernobyl reactor #4 insides, they would understand why you want to upgrade your version.

    There is a lot of pressure on us, the developers, for supporting 1.8 in our plugins. It isn't that we hate the version, if we can support it easily, we could do it, but as most of the people here mentioned most of the plugin developers here are hobbyists, they can't maintain such layers on layers on layers to support 1.8. And even when you add 1.8 support, you still will have 1 bug down there, and some kid post it as a 1 star review on your plugin saying "pIeCe Of ShIt DeVeLoPeR 1.8 sUpPoRt NoT wOrKinG (stacktrace)" and then you basically rage quit and remove the whole 1.8 support, but ONLY 5 SECONDS after you posted the update and you stated you remove 1.8 support, THE SAME KID comes and rates your plugin 1 star AGAIN, because you removed 1.8 support.

    With the latest updates and one which is completely breaking, having a plugin with items which you want to support 1.13- but still want to support 1.13+, you need a bunch of hacks, that's why most of the developers completely ditch 1.13- .

    I refuse the claim from server owners that 1.13+ is laggy. IT ISN'T ANYMORE . With the release of 1.15, it is much more performant than the version before - 1.14, which yea was laggy, but after tweaking settings isn't that much. If 1.15 was laggy, there won't be theories in youtube that the oldest anarchy server 2b2t would probably jump from 1.12 to 1.15 .
     
    • Agree Agree x 2
    • Funny Funny x 1
  14. So here's the biggest I problem I see with an older version vs new version.
    It's really, stupidly simple.

    Old Version: "Oh! A brand new plugin that looks REALLY cool!"
    New Plugin: "Yeah, neat huh!? Too bad you aren't updated to use me! LUL!"
    Old Version: "What!? Why!? Why are you forgetting about the classic 1.X version! It's SO much better than 1.XY version! Support me!"
    New Plugin: "Yeah no, you want it, you update. I don't have to cater to you."

    Or, you get something like this..
    Old Version: "Gee, I wish something new would happen, this is getting rather repetitive or whatever."
    Plugin: "New release with some shiny new features!"
    Old Version: "Oh awesome! New stuff to use/do/try!"
    Plugin: "Nope, sorry. We stopped supporting your version because it's several versions outdated now. You'll have to update if you want the new stuff."
    Old Version: "What!? That's not fair!!! Why are you dropping support for my version!?"

    What it boils down to...
    Minecraft updates, plugins update with minecraft.
    If there's no NEED for you to update, why is it a big deal?
    If you NEED to update, then I guess you NEED to update. It's as simple as that.
    Developers who choose to drop support for older versions are allowed to do that, 100%. If we're going to sit her and blame players for not wanting to play on a newer version that what you're offering them then that's on them. You make it on you when you decide to continue to cater to them. "Shooting yourself in the foot" as they say.

    One thing I've always said, is "When you pay for the service, put the work into the service, manage the service. It becomes YOUR service and you can do with it as you please.
    Are you not the one who paid for it? Are you not the one who puts the work into it? Are you not the one who manages it?
    So who's service is it?
    Sounds like it's yours... BUT what I'm hearing is that in reality you've allowed players, typically children to take control of your service and are now wanting to do the same to the Developers who have decided (for whatever reason they so CHOOSE) to drop support for older versions or refuse to include support for older versions in the first place.

    In the end, you are making a choice to be on whatever version you are on. What your reasons for doing so are, are meaningless to everyone you're trying to make a plea to. It doesn't make a difference to them, except for the fact that you're asking for them to work harder to maintain something simply because you feel it's important to do so.

    So, let me try that:
    "I want your server to support 1.15! I want to see bees! It's important to have bees! All the new stuff is important to me, and lots of other people like the bees too! Why don't you want to give us bees!"

    See how that works? ;P
     
    • Agree Agree x 4
  15. I think one of the important things that developers don't seem to understand because most are just making their plugins and don't run servers. A a server owner we have to make a choice. Do we want a server with 100+ players with tons of things for them to do OR do we want a server with 25-30 players with very little for them to do.

    Minecraft servers just don't run well on latest version of minecraft. From what I've seen 1.16 is going to have even more new mechanics, mobs and items and none of the issues with running servers are getting addressed. (it's just going to get worse for server owners)

    If you want to develop for servers and actually sell your plugins, you'd be better off supporting 1.8 - 1.13.2 and have a lot more server owners that can buy your plugins.

    Pretty much everyone that I have talked to (including myself) have tried to go to the latest version and it's nothing but regrets! The performance is soooo shitty that it's just pointless.
     
    • Optimistic Optimistic x 3
    • Winner Winner x 1
  16. What? I get that 1.13 was bad and 1.14 was even worse, but is 1.15 so bad? Also what is wrong with 1.12 now? It's not every version post 1.8 that has bad performance?
     
    • Like Like x 1
  17. Best performance: 1.13, 1.15, 1.14, in that order. Pre 1.13, dunno. Performance only started going down slowly after 1.13 since it had a massive technical overhaul.

    We updated to 1.15. We support 1.15 connections. Nothing more, nothing less. 1.15 only; deal with it. We want you to play our game the way its intended to be played, which uses 1.15 mechanics. Hacking old version support just ruins gameplay experience.
     
    • Agree Agree x 9
  18. electronicboy

    IRC Staff

    It's not that devs don't understand, making that statement honestly makes it seem like you're missing the point. Anybody who is against people running older versions is a bit 'eh, it has no impact on them, if you wanna run outdated software, go for it, nobody can stop you. Just, don't expect people to still provide support for that version.

    The entire situation is pretty much that your average plugin dev who doesn't deal with the premium plugin system, you likely earn more in a day on your server than they do in a month, heck, even a year. Why would devs care about tryna maintain support for a 5 year old version when they don't get any gains from it?

    These are often the people who are actually looking after their plugins well and having fun with development, premium plugins are a bit different in that they're tryna sell a product and actually get something from what they're doing, and even then, the entire system is a bit of a rip off, you've gotta actually get a consistent number of sales in order to justify the time spent on it, and, tbqh, I've personally made a decision that I ain't gonna bother touching any premium plugins due to the horrors I've seen.
     
    • Winner Winner x 4
    • Agree Agree x 1
  19. bStats has already been shown here.
    1.8.8 takes up about roughly 15% of all servers
    1.12.2 takes up 14%
    1.13.2 takes up 3.8%
    1.9-1.11.2 takes up like 1%

    Roughly 60% of servers are on 1.14+ .... but you're telling devs to support 1.8-1.13.2 ??!?!??? WHY?
    "have a lot more server owners that can buy your plugins." <-- what the actual fuck? How exactly, When 60% of servers are running 1.14+???
     
    • Agree Agree x 3
  20. I personally support 1.8 in my plugins at least for now, but to be honest, I'm rather disappointed.

    My plugin is equally useful to server types where 1.8 has a bigger share and modern servers; it was originally created for a Factions server. So I thought keeping support for 1.8 would give it a broader user base, which means more feedback, bug reports, contributions, and in general a bigger community where people can help each other out setting it up.

    The thing is, many owners of small servers don't even update their plugins. They wait for Minecraft updates, grab the first compatible dev build we release and keep it like that until the next Minecraft update is out. And in my experience, an even higher percentage of the 1.8.8 servers are maintained that way, with the difference that their owners ignore Minecraft updates as well and therefore never update the plugin either.

    1_8.png
    (Note: I'm using bStats since May 2018)

    Even if I do support 1.8, my efforts hardly reach any 1.8 server admins - except the new ones who just found my plugin recently.

    I'd also like to point out that developers don't do that out of evil intend. Often, a plugin doesn't break immediately when a new Minecraft/Bukkit version is out, but some methods they use became deprecated since then.

    For example, the methods PlayerInventory#getItemInMainHand() and #getItemInOffHand() have been added to Bukkit 1.9 to replace the old #getItemInHand(). Since then, the deprecated #getItemInHand() simply returns #getItemInMainHand() and plugins that still use it work with both 1.8.8 and 1.15.2. But this backwards compatibility is paid with forward compatibility: It is usually a matter of time until deprecated methods are removed. A developer who still uses #getItemInHand() risks that his plugin unnecessarily breaks with an upcoming release just to keep support for 1.8.8, so it's more than reasonable for him to update to #getItemInMainHand() even if it breaks backwards compatibility without an acute, visible need for it.
     
    • Agree Agree x 5
    • Winner Winner x 1
Thread Status:
Not open for further replies.