Spigot Transport-Pipes 5.0.0

This plugin adds Transport-Pipes to Minecraft

  1. Hello author

    This plugin can cause a very serious problem: there are a lot of problems when placing the block, but I can't send the video, please try it yourself.

    description:
    It is no problem to place two and a slabs in a flat area to form an entire square. However, when there is a block in the previous grid, it is impossible to insert a slab in the middle.

    Different locations will have different bugs, but the situation is the same: I can't place slab

    (Forgive my English
     
    #301 Auroman, May 21, 2019
    Last edited: May 23, 2019
  2. Also found that iron blocks cant be made with the crafting pipe, it will make nuggets not blocks
     
  3. The crafting bugs are known and fixed in the next release
     
  4. #304 BlackBeltPanda, May 22, 2019
    Last edited: May 23, 2019
    • Like Like x 1
  5. It seems that the pipe doesn't read well at server startup.
    Code (Text):

    [04:14:25] [Server thread/WARN]: java.lang.NullPointerException
    [04:14:25] [Server thread/WARN]:    at de.robotricker.transportpipes.saving.LegacyDuctLoader_v4_3_1.loadDuctsSync(LegacyDuctLoader_v4_3_1.java:50)
    [04:14:25] [Server thread/WARN]:    at de.robotricker.transportpipes.saving.DiskService.loadDuctsSync(DiskService.java:54)
    [04:14:25] [Server thread/WARN]:    at de.robotricker.transportpipes.TransportPipes.lambda$onEnable$1(TransportPipes.java:146)
    [04:14:25] [Server thread/WARN]: [TransportPipes] Task #227 for TransportPipes v5.0.0-bCUSTOM generated an exception
    java.lang.NullPointerException: null
       at de.robotricker.transportpipes.log.SentryService.record(SentryService.java:45) ~[?:?]
       at de.robotricker.transportpipes.saving.DiskService.loadDuctsSync(DiskService.java:59) ~[?:?]
       at de.robotricker.transportpipes.TransportPipes.lambda$onEnable$1(TransportPipes.java:146) ~[?:?]
       at org.bukkit.craftbukkit.v1_13_R2.scheduler.CraftTask.run(CraftTask.java:84) ~[patched_1.13.2.jar:git-Paper-614]
       at org.bukkit.craftbukkit.v1_13_R2.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:449) ~[patched_1.13.2.jar:git-Paper-614]
       at net.minecraft.server.v1_13_R2.MinecraftServer.b(MinecraftServer.java:1010) ~[patched_1.13.2.jar:git-Paper-614]
       at net.minecraft.server.v1_13_R2.DedicatedServer.b(DedicatedServer.java:439) ~[patched_1.13.2.jar:git-Paper-614]
       at net.minecraft.server.v1_13_R2.MinecraftServer.a(MinecraftServer.java:940) ~[patched_1.13.2.jar:git-Paper-614]
       at net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:837) ~[patched_1.13.2.jar:git-Paper-614]
       at java.lang.Thread.run(Thread.java:748) [?:1.8.0_171]
     
     
    #305 kotarobo, May 23, 2019
    Last edited: May 23, 2019
  6. Does not work with version 1.14.1 update pliz.
     
  7. Facing two one way pipes towards each other and feeding them items can timeout the server. Discovered this the hard way, lol.
     
  8. Hello author,
    after installing the pipes plugin, there will be problems with the slabs placement.

    (GIF)
    [​IMG]
     
    #308 Auroman, May 31, 2019
    Last edited: Jun 1, 2019
  9. any news on 1.14.3-1.14.4?
     
  10. Will you add support for spigot 1.15.1?
     
    • Like Like x 2
    • Like Like x 2
    • Like Like x 1
  11. this plugin will not continue to be developed? any alternative for 1.16.2?
     
  12. he suddenly abandoned it sadly
     
  13. An Update for 1.16.4 would be so nice ;-)

    Are you still working on this plugin @BlackBeltPanda
     
  14. Good day,
    it would be really cool if the plugin is updated to the latest Minecraft version.
     
  15. Can you update this to work with 1.16.5 please? :)
     
  16. I finally found some time to update my fork of this plugin for 1.17.1 if anyone is interested. Like I mentioned above, there are some differences in the way the plugin works compared to the version available here on Spigot. You can find the 1.17.1 release here: https://github.com/BlackBeltPanda/Transport-Pipes/releases

    Note that I've only lightly tested it and there may be bugs. Requires ProtocolLib 4.7.0. Make a backup of your ducts.dat file before loading the plugin, just in case.
     
    #320 BlackBeltPanda, Jul 30, 2021
    Last edited: Jul 30, 2021
    • Winner Winner x 1