Spigot TreasureChest-Reloaded 8.5-R

Plugin made by Mtihc, just porting it to the new bukkit versions

  1. @Wolfezz can u help me? i am 8.5 and when i wanna update to 8.5.1 it broke my config :( created a new folder but doesn't work if i copy them
  2. Does this support 1.15.2?
  3. Don't tested yet, give it a try and send me the answer. If not, I'll post a 1.15.2 build
  4. Hey !
    First of all, gongratulation for this plugin, it respond perfectly to the needs and is really easy to use ! I used it a few years ago on an old 1.7 server and i'd like to use it again for a new server but I can't make this build works.

    I've tried to install it on a 1.15.2 and on a 1.16 server but i keep getting errors caused by world guard (I guess)
    Even with IP enabled, world guard seems to block the chest opening.
    When user are op or belongs to the region it works perfectly but I didn't manage to make it works for protected area.
  5. On some chests, when i run /tchest set, the inventory gets emptied. This is really causing trouble for me
  6. Server Info: 1.15.2 Paper
    Permission plugin: Luck Perm
    plugin verision: TreasureChest-8.5
    there are some promblem of /tchest rank
    I set up a tchest then user /tchest rank add XXX
    and i give the permission to player treasurechest.rank.XXX
    when i open the chest the consloe show this

    [ERROR] .... Could not pass event PlayerInteractEvent to TreasureChest v8.5

    java.lang.NullPointerException: null

    at com.mtihc.minecraft.treasurechest.v8.core.TreasureManager.getRanks(TreasureManager.java:513) ~[?:?]

    at com.mtihc.minecraft.treasurechest.v8.core.TreasureManager.checkRank(TreasureManager.java:544) ~[?:?]

    at com.mtihc.minecraft.treasurechest.v8.core.TreasureManager.onPlayerInteract(TreasureManager.java:245) ~[?:?]

    at com.mtihc.minecraft.treasurechest.v8.core.TreasureChestListener.onPlayerInteract(TreasureChestListener.java:66) ~[?:?]

    at java.lang.invoke.VirtualHandle.invokeExact_thunkArchetype_V(VirtualHandle.java:85) ~[?:1.8.0_212]

    at java.lang.invoke.AsTypeHandle.invokeExact_thunkArchetype_X(AsTypeHandle.java:49) ~[?:1.8.0_212]

    at com.destroystokyo.paper.event.executor.MethodHandleEventExecutor.execute(MethodHandleEventExecutor.java:37) ~[patched_1.15.2.jar:git-Paper-353]

    at co.aikar.timings.TimedEventExecutor.execute(TimedEventExecutor.java:80) ~[patched_1.15.2.jar:git-Paper-353]

    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:70) ~[patched_1.15.2.jar:git-Paper-353]

    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:607) ~[patched_1.15.2.jar:git-Paper-353]

    at org.bukkit.craftbukkit.v1_15_R1.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:471) ~[patched_1.15.2.jar:git-Paper-353]

    at net.minecraft.server.v1_15_R1.PlayerInteractManager.a(PlayerInteractManager.java:456) ~[patched_1.15.2.jar:git-Paper-353]

    at net.minecraft.server.v1_15_R1.PlayerConnection.a(PlayerConnection.java:1414) ~[patched_1.15.2.jar:git-Paper-353]

    at net.minecraft.server.v1_15_R1.PacketPlayInUseItem.a(PacketPlayInUseItem.java:27) ~[patched_1.15.2.jar:git-Paper-353]

    at net.minecraft.server.v1_15_R1.PacketPlayInUseItem.a(PacketPlayInUseItem.java:5) ~[patched_1.15.2.jar:git-Paper-353]

    at net.minecraft.server.v1_15_R1.PlayerConnectionUtils.lambda$ensureMainThread$0(PlayerConnectionUtils.java:23) ~[patched_1.15.2.jar:git-Paper-353]

    at net.minecraft.server.v1_15_R1.PlayerConnectionUtils$$Lambda$5848.000000005D1A5BD0.run(Unknown Source) ~[?:?]

    at net.minecraft.server.v1_15_R1.TickTask.run(SourceFile:18) ~[patched_1.15.2.jar:git-Paper-353]

    at net.minecraft.server.v1_15_R1.IAsyncTaskHandler.executeTask(IAsyncTaskHandler.java:136) ~[patched_1.15.2.jar:git-Paper-353]

    at net.minecraft.server.v1_15_R1.IAsyncTaskHandlerReentrant.executeTask(SourceFile:23) ~[patched_1.15.2.jar:git-Paper-353]

    at net.minecraft.server.v1_15_R1.IAsyncTaskHandler.executeNext(IAsyncTaskHandler.java:109) ~[patched_1.15.2.jar:git-Paper-353]

    at net.minecraft.server.v1_15_R1.MinecraftServer.ba(MinecraftServer.java:1105) ~[patched_1.15.2.jar:git-Paper-353]

    at net.minecraft.server.v1_15_R1.MinecraftServer.executeNext(MinecraftServer.java:1098) ~[patched_1.15.2.jar:git-Paper-353]

    at net.minecraft.server.v1_15_R1.IAsyncTaskHandler.awaitTasks(IAsyncTaskHandler.java:119) ~[patched_1.15.2.jar:git-Paper-353]

    at net.minecraft.server.v1_15_R1.MinecraftServer.sleepForTick(MinecraftServer.java:1059) ~[patched_1.15.2.jar:git-Paper-353]

    at net.minecraft.server.v1_15_R1.MinecraftServer.run(MinecraftServer.java:974) ~[patched_1.15.2.jar:git-Paper-353]

    at java.lang.Thread.run(Thread.java:813) [?:1.8.0_212]
  7. It is compiled againgst 1.16, haven't tried 1.15. Is WorldEdit 7.x installed?
  8. The WorldEdit plugin verision is 7.1.0;8e55131
    Minecraft Verision is 1.15.2
  9. Having an issue where sometimes it is saving the treasure chest in yml, but doesn't recognize it in-game as a treasure chest, and simply empties the chest and treats it as a vanilla chest.

    This only seems to be happening with double chests, and if I break the non-targeted half of the chest (after /tchest set), the single chest then works as a treasure chest. Adding the other half of the chest back prevents it from being recognized again.

    This is happening in seemingly random spots, as some of them work perfectly fine.

    Inventory doesn't seem to be the issue, as I have tested it with custom items and nothing but a few vanilla items, and it's the same result. It seems to be location based.

    There is nothing covering it or anything. It just doesn't work sometimes, but does store the yml file.

    I am on 1.15.2 paper using latest version of treasurechest and worldedit 7.1.0
  10. It's a great plugin! Does it support Group manager as a permissions plugin for the rank system (treasurechest.rank.X), and is the plugin able to run on 1.14.4 server?
  11. Works as intended (mostly). When we updated from 1.15 to 1.16 it created a new folder but I zipped up the old one and put it in the new one and all the treasure chests came back.

    I am experiencing something odd that never happened however. When I take an item out of a treasure chest with a custom name it changes its data ever so slightly so it can't be traded with a villager with custom trades.

    It means I've had to set up a funky system of taking out a different item and then making that item turn into the item I need via another plugin.
  12. Does the plugin work on 1.15.2?
  13. Mostly yes.
  14. Is there a way to make this work with trapped chests? I want to put a commandblock under my chest that has a tellraw command in it, but when i make the trapped chest a tchest, it stops outputting a redstone signal. Or, if I'm doing it wrong, is there a way to make it broadcast to everyone using tellraw ?
  15. Make sure the block ontop of the chest is air.
  16. It works now! Thank you
    • Like Like x 1
  17. How to add items to chest?