Solved Trouble setting up BungeeCord config.yml

Discussion in 'BungeeCord Help' started by Coolkc456, May 11, 2017.

Thread Status:
Not open for further replies.
  1. Hello, I'm trying to install BungeeCord for my server and I keep getting this error:
    1. 11.05 00:05:44 [Server] SEVERE Exception in thread "main"
    2. 11.05 00:05:44 [Server] SEVERE java.lang.IllegalArgumentException: Server lobby (priority 0) is not defined
    3. 11.05 00:05:44 [Server] SEVERE at com.google.common.base.Preconditions.checkArgument(Preconditions.java:145)
    4. 11.05 00:05:44 [Server] SEVERE at net.md_5.bungee.conf.Configuration.load(Configuration.java:123)
    5. 11.05 00:05:44 [Server] SEVERE at net.md_5.bungee.BungeeCord.start(BungeeCord.java:265)
    6. 11.05 00:05:44 [Server] SEVERE at net.md_5.bungee.BungeeCordLauncher.main(BungeeCordLauncher.java:55)
    7. 11.05 00:05:44 [Server] SEVERE at net.md_5.bungee.Bootstrap.main(Bootstrap.java:15)
    This is the full startup log: https://pastebin.com/URRFRXAU
    Here is my config.yml: https://pastebin.com/EFK2KqEH

    I tried running my config through a YAML parser and it said my forced_hosts column was incorrect but every time I change it so that it can be correctly "parsed", the config changes it back to where it was before I parsed it. I don't know if that's the issue. Can anyone tell me what I'm doing wrong?
     
  2. That means the server "lobby" is not defined in the servers. You only have survival set as the server, and no lobby. The priority section in line 25-26, says "priority: lobby" when there isn't a lobby. To fix this, change lobby to survival. Watch your caps!
     
  3. Your main server is set to "lobby" check your settings, you might have the "lobby/hub" server named something else inside the servers list
     
  4. You have prioritized a server called "lobby", which does not exist. The only server you have is "survival". So, either change the priority from "lobby" to "survival", or make lobby server named "lobby"
     
  5. Why did everyone post their answer right after I posted mine... .-.

    what a coincidence... lol
     
  6. new thread, our answers were submitted at the same time, @ryans1230 's a minute later
     
  7. Well, it's all posted within 15 seconds. He just posted it on a different minute, that's why it shows a minute difference.
     
  8. I edited the config and changed the lobby under priorities to survival and the console has no errors but I haven't been able to test if it works since Mojang's authentication servers are down but I'll let you know if it worked because I think it did. :)
     
  9. Hey guys, so although I'm not getting any errors in the console, for some reason I can't connect to the Bungeecord server's IP. I get the error: "java.net.ConnectException: Connection refused: no further information" and the server does not load in my server list yet the console says it is listening. Here is my current config: https://pastebin.com/sHDWRZbP

    http://prntscr.com/f76fs2
     
  10. You are trying to connect to 192.99.21.76:25577, correct? Your query_listener is the bungee's port, aka the port you're going to connect to the network with.
     
Thread Status:
Not open for further replies.