1.14.4 Trouble with SQL Connection Pooling

Discussion in 'Spigot Plugin Development' started by Neoblade298, Mar 23, 2020.

  1. Hey there,

    I've spent the better part of the day trying to figure out c3p0's connection pooling and I'm caught on the stupidest snag.

    [​IMG]
    https://gyazo.com/3f275c50e0c2b83ab906f01fe800ee2e

    I get this error on the startup in my plugin. Here is the relevant code:

    [​IMG]
    https://gyazo.com/4f0bcf1d592cdcc6510b0b52ebc00815

    Line 38 of main is the line that starts with "DataSource pool = ". There's really nothing complex going on here. I'm literally INITIALIZING a connection pool. I also tried the even simpler ComboPooledDataSource cpds = new ComboPooledDataSource();. It results in the same error.
    [​IMG]
    https://gyazo.com/a33c57d97d6bc5a099876475a2f9ea9d

    Everything necessary is in my build path, and I've even opened up the JAR file that I export to make sure it was in the .classpath. Eclipse doesn't give any sort of error hinting towards me not having a dependency. What am I doing wrong?
     
    #1 Neoblade298, Mar 23, 2020
    Last edited: Mar 23, 2020
  2. Had you shaded the dependency into your JAR yet?
     
  3. Sorry, I'm really unfamiliar with shading and how it's done. Can you point me in the right direction? You don't have to give me a step by step, though I'd appreciate a link to a basic tutorial (I tried myself on google and wasn't sure what was right). Thanks for the help!