Ubuntu Help

Discussion in 'Systems Administration' started by Hamburger123598, Jun 14, 2016.

  1. Hey,

    I have had no error with screens until now, when i run the start.sh file in a screen session it will cause the following error when booting the server up!

    -e Starting example 1 with a 4096MB RAM cap
    Loading libraries, please wait...
    [15:57:55 INFO]: Starting minecraft server version 1.8.8
    [15:57:55 INFO]: Loading properties
    [15:57:55 INFO]: Default game type: ADVENTURE
    [15:57:55 INFO]: This server is running CraftBukkit version git-Spigot-db6de12-18fbb24 (MC: 1.8.8) (Implementing API version 1.8.8-R0.1-SNAPSHOT)
    [15:57:55 ERROR]: Encountered an unexpected exception
    java.lang.UnsatisfiedLinkError: /usr/lib/jvm/java-8-oracle/jre/lib/amd64/libawt_xawt.so: libXrender.so.1: cannot open shared object file: No such file or directory
    at java.lang.ClassLoader$NativeLibrary.load(Native Method) ~[?:1.8.0_91]
    at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1941) ~[?:1.8.0_91]
    at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1824) ~[?:1.8.0_91]
    at java.lang.Runtime.load0(Runtime.java:809) ~[?:1.8.0_91]
    at java.lang.System.load(System.java:1086) ~[?:1.8.0_91]
    at java.lang.ClassLoader$NativeLibrary.load(Native Method) ~[?:1.8.0_91]
    at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1941) ~[?:1.8.0_91]
    at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1845) ~[?:1.8.0_91]
    at java.lang.Runtime.loadLibrary0(Runtime.java:870) ~[?:1.8.0_91]
    at java.lang.System.loadLibrary(System.java:1122) ~[?:1.8.0_91]
    at java.awt.Toolkit$3.run(Toolkit.java:1636) ~[?:1.8.0_91]
    at java.awt.Toolkit$3.run(Toolkit.java:1634) ~[?:1.8.0_91]
    at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_91]
    at java.awt.Toolkit.loadLibraries(Toolkit.java:1633) ~[?:1.8.0_91]
    at java.awt.Toolkit.<clinit>(Toolkit.java:1668) ~[?:1.8.0_91]
    at sun.awt.AppContext$2.run(AppContext.java:277) ~[?:1.8.0_91]
    at sun.awt.AppContext$2.run(AppContext.java:266) ~[?:1.8.0_91]
    at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_91]
    at sun.awt.AppContext.initMainAppContext(AppContext.java:266) ~[?:1.8.0_91]
    at sun.awt.AppContext.access$400(AppContext.java:135) ~[?:1.8.0_91]
    at sun.awt.AppContext$3.run(AppContext.java:321) ~[?:1.8.0_91]
    at sun.awt.AppContext$3.run(AppContext.java:304) ~[?:1.8.0_91]
    at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_91]
    at sun.awt.AppContext.getAppContext(AppContext.java:303) ~[?:1.8.0_91]
    at javax.imageio.spi.IIORegistry.getDefaultInstance(IIORegistry.java:154) ~[?:1.8.0_91]
    at javax.imageio.ImageIO.<clinit>(ImageIO.java:66) ~[?:1.8.0_91]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadServerIcon0(CraftServer.java:1660) ~[spigot-1.8.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadIcon(CraftServer.java:749) ~[spigot-1.8.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.<init>(CraftServer.java:250) ~[spigot-1.8.jar:git-Spigot-db6de12-18fbb24]
    at net.minecraft.server.v1_8_R3.PlayerList.<init>(PlayerList.java:71) ~[spigot-1.8.jar:git-Spigot-db6de12-18fbb24]
    at net.minecraft.server.v1_8_R3.DedicatedPlayerList.<init>(SourceFile:14) ~[spigot-1.8.jar:git-Spigot-db6de12-18fbb24]
    at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:176) ~[spigot-1.8.jar:git-Spigot-db6de12-18fbb24]
    at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525) [spigot-1.8.jar:git-Spigot-db6de12-18fbb24]
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_91]

    I am unsure of this error as it does not occur outside of the screen session, if i was to bash the start.sh in a normal session it would run with 0 errors! Any help with this error is needed!

    Thanks,

    Jack!
     
  2. I have java installed on the machine and have re-installed java-8
     
  3. have you tried openjdk-default?
     
    • Informative Informative x 1
  4. @OP It seems you've installed Java without a graphical server! This is good when used correctly.
    Try passing "-Djava.awt.headless=true" in your Java flags.

    This will send him on an endless journey to manually download each Xorg package.
     
    • Useful Useful x 1
  5. Thank you for this easy fix, i am unsure why this error has only just occurred as it worked before! But thank you again for this fix!
     
  6. Is this one a new system / machine? Or did you recently update Java or anything along those lines?
     
  7. As far as I remember I haven't updated java or anything. I re-installed Ubuntu about a month ago, but aside from that I haven't done much. Maybe when I apt-get updated during the initial re-install something happened.. No idea tbh.
     
  8. sudo apt-get update
    sudo apt-get install default-jre
    sudo apt-get install default-jdk
     
  9. Thank you for your help, but thats not nearly the problem I've been having, and my problem was also solved already. I appreciate the answer though :)