Unable to pvp.

Discussion in 'Spigot Help' started by ChickenSaysBak, May 9, 2016.

  1. So I am trying to add a certain area where pvp is allowed in my server. I started by adding "pvp" to the worldguard region. Pvp wasn't working. Then I figured that it might be because the server properties file had pvp set to false so I made it true. Pvp is still not working o-o What do I do? lol
     
  2. Is it in another region with higher priority? Do you have multiverse? Is the server on peaceful?
     
  3. Is your pvp arena near the world spawn? If it is, go to your server.properties then change spawn-protection to 0! That should work! :)
     
  4. Only 1 region, yes multiverse, and its on easy mode.

    That might be what it is, ill try it when im home. Wait does spawn protection happen in all worlds or only the original world because its a multiverse world ;P
     
  5. Its probably because you have pvp disabled for that world in worlds.yml
     
    • Useful Useful x 1
  6. Do you have 2 set regions in a certain place? Then do /rg priority pvp 1.
     
  7. I don't even have a world.yml :eek:

    Also about spawn protection, it was already on 0. And no there's only 1 region at the spot.
     
  8. He means that in your world.yml (can be found in your multiverse folder), the pvp option is disabled.
     
  9. May i see your plugins? Its very hard to determine a problem if you dont show your plugins. :(
     
  10. I think this may be the problem:
    1. A plugin may cause bugs with MV. [Mostly by: Factions , GroupManager/other perm plugin]
    2. A little bit of an bug can be happening with it if you said "pvp deny". It is caused for me too *was caused*
     
  11. I have a feeling this is what it was, pvp was disabled on the world I wanted in multiverse. I will try it later when one of my friends join. Thx ;)
     
  12. Is your server offline mode? I can join if you want :)
     
    • Funny Funny x 1
  13. I think this can help:
    /rg flag <name> pvp allow
    /rg setpriority <name> 999
     
    • Like Like x 1
  14. in worldguard, if you have a region in a region and the region on the outside has pvp off, pvp will be on on the second region but because it doesnt really know in which region you are pvp is still not allowed. Try making the 2nd region the primary one,
     
    • Funny Funny x 1
  15. Yeah as mentioned before, the regions don't have anything to do with it because 1. There is only 1 region, none or overlaping and 2. They are already set to pvp. Once again, I am almost certain this was because of multiverse and I will test it tomorrow when my friend comes on. :)
     
    • Like Like x 1
  16. Okay, I hope you will finde it. Do you know the 16Block WorldSpawn protection?
     
    • Agree Agree x 1
  17. /region flag {REGIONNAME} pvp deny
     
    • Funny Funny x 1