Solved Unable to retrieve the spigot-api in gradle

Discussion in 'Spigot Plugin Development' started by Andre_601, Jan 17, 2020.

  1. Andre_601

    Supporter

    Did you guys somehow mess up the API?

    When trying to use the 1.15.1 spigot API in the build.gradle (Following the instructions on the wiki) does gradle cry around about not being able to find net.md-5:bungeecord-chat:1.13-SNAPSHOT in any of the repositories.
    If that is (somehow) intended, pleas update the wiki page accordingly as it is a huge annoyance to deal with this right now.

    And to clarify: I want to make a multi-module project and setup the main build.gradle with the settings required and tried compile and compileOnly without any difference in the module's build.gradle.
     
  2. Andre_601

    Supporter

    Seems to be solved.

    For all the people wondering:
    You have to use mavenLocal() instead of that entire maven{ url = "https://hub.spigotmc.org/nexus/content/repositories/snapshots" } part as it seems like the nexus doesn't contain all required dependencies of spigot.
     
  3. You need the sonatype repo for the extra deps.
     
  4. Andre_601

    Supporter

    Then the wiki is outdated and wrong as it only says to add the link to the nexus repo of spigot and then add spigot-api as dependency for it.
     
  5. Puremin0rez

    Moderator

    Bungeecord uses a different maven repository which I think is a bit weird - this has caught me off guard a few times too.

    Sonatype is the correct repo to use in addition to the spigot repository to have all dependencies needed.
     
  6. https://www.spigotmc.org/wiki/spigot-gradle/ It says on here to add sonatype, idk what you’re talking about.
     
  7. Andre_601

    Supporter