Solved Unsupported Class Version Error

Discussion in 'Spigot Plugin Help' started by Lilmurf, Jul 8, 2016.

  1. Hello smart people!

    I am getting an error with most of the plugins I try to install. World Edit and EssentialsX being the two most important.

    [15:25:04 ERROR]: Could not load 'plugins/worldedit-bukkit-6.1.3.jar' in folder 'plugins'

    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: com/sk89q/worldedit/bukkit/WorldEditPlugin : Unsupported major.minor version 51.0

    This is the error message for all the plugins not working.

    Here is the full log when I start up my server:
    http://pastebin.com/TbPEb1qq

    I am using Java 8, the newest version of World Edit, and PermissionsX, and running a 1.10.2 Spigot Server.
    Help me smart people! You're my only hope!

    And thanks a million in advance!
     
    #1 Lilmurf, Jul 8, 2016
    Last edited: Jul 8, 2016
  2. You are running Java 8 while the plugin requires Java 7
     
  3. MiniDigger

    Supporter

    how can the plugin require java 7? if it was compiled with java 7 it should run on java 8 without a problem.
     
  4. java.lang.UnsupportedClassVersionError happens because of a higher JDK during compile time and lower JDK during runtime.
     
  5. MiniDigger

    Supporter

    yep, but 51 is java 7 so the runtime complains that it can't run java 7. this should only be the case if the runtime is java 6

    @Lilmurf what is the output when you enter "java -version" into your cmd/terminal/ssh connection?
     
    • Like Like x 1
  6. Woops, probably switched it :p
     
  7. Inkzzz

    Resource Staff

    Update to Java 8 'cause all developers love it.
     
  8. Thanks for the quick responses guys!

    java version "1.6.0_65"

    Java(TM) SE Runtime Environment (build 1.6.0_65-b14-468-11M4833)

    Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-468, mixed mode)

    @MiniDigger

    Strange, so it looks like its running 1.6, but my system preferences show 1.8

    Screen Shot 2016-07-08 at 6.14.50 AM.png
     
    #8 Lilmurf, Jul 8, 2016
    Last edited: Jul 8, 2016
  9. So you need to update your java version, you really shouldn't be on Java 6 anymore.
     
  10. @ConnorLinfoot I just updated my previous post, my system preferences says that I am running 8. Any ideas why the terminal is running 6?
     
    • Like Like x 1
  11. It looks like that did the trick! Thanks all of you for your help! :D