Unusual Errors with WorldGuard and TreasureChest

Discussion in 'Spigot Plugin Help' started by phospholipid, Jun 9, 2017.

  1. There is something goofy going on with two of my plugins. I'm wondering if any of you folks could help me understand the problem.

    1) TreasureChest-Reloaded is having some kind of issue. I don't even know how to parse it. It is completely updated to the most recent version.

    [22:14:07 INFO]: [TreasureChest] Enabling TreasureChest v8.5

    [22:14:07 ERROR]: Error occurred while enabling TreasureChest v8.5 (Is it up to date?)

    java.lang.NoSuchMethodError: org.bukkit.configuration.file.YamlConfiguration.loadConfiguration(Ljava/io/InputStream;)Lorg/bukkit/configuration/file/YamlConfiguration;

    at com.mtihc.minecraft.treasurechest.v8.plugin.util.YamlFile.setDefaults(YamlFile.java:70) ~[?:?]

    at com.mtihc.minecraft.treasurechest.v8.plugin.util.YamlFile.reload(YamlFile.java:58) ~[?:?]

    at com.mtihc.minecraft.treasurechest.v8.plugin.TreasureChestPlugin.onEnable(TreasureChestPlugin.java:65) ~[?:?]

    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:264) ~[spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:337) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:402) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugin(CraftServer.java:377) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugins(CraftServer.java:327) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at org.bukkit.craftbukkit.v1_12_R1.CraftServer.reload(CraftServer.java:748) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at org.bukkit.Bukkit.reload(Bukkit.java:525) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:25) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at org.bukkit.craftbukkit.v1_12_R1.CraftServer.dispatchCommand(CraftServer.java:644) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at org.bukkit.craftbukkit.v1_12_R1.CraftServer.dispatchServerCommand(CraftServer.java:630) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at net.minecraft.server.v1_12_R1.DedicatedServer.aP(DedicatedServer.java:443) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at net.minecraft.server.v1_12_R1.DedicatedServer.D(DedicatedServer.java:406) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at net.minecraft.server.v1_12_R1.MinecraftServer.C(MinecraftServer.java:678) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:576) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_112]

    2) My WorldGuard is having an issue. One thing I notice right away is that it says it is loading version 6.1.3, but in my plugins folder is worldguard-6.2.jar, so that seems weird. Otherwise, I don't know what it's trying to tell me.

    [22:14:07 INFO]: [WorldGuard] Enabling WorldGuard v6.1.3-SNAPSHOT;c904242

    [22:14:07 ERROR]: Error occurred while enabling WorldGuard v6.1.3-SNAPSHOT;c904242 (Is it up to date?)

    java.lang.NoSuchMethodError: com.google.common.util.concurrent.MoreExecutors.sameThreadExecutor()Lcom/google/common/util/concurrent/ListeningExecutorService;

    at com.sk89q.worldguard.internal.guava.cache.LocalCache.<clinit>(LocalCache.java:77) ~[?:?]

    at com.sk89q.worldguard.internal.guava.cache.LocalCache$LocalLoadingCache.<init>(LocalCache.java:4798) ~[?:?]

    at com.sk89q.worldguard.internal.guava.cache.CacheBuilder.build(CacheBuilder.java:793) ~[?:?]

    at com.sk89q.worldguard.session.SessionManager.<init>(SessionManager.java:62) ~[?:?]

    at com.sk89q.worldguard.bukkit.WorldGuardPlugin.onEnable(WorldGuardPlugin.java:170) ~[?:?]

    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:264) ~[spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:337) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:402) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugin(CraftServer.java:377) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugins(CraftServer.java:327) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at org.bukkit.craftbukkit.v1_12_R1.CraftServer.reload(CraftServer.java:748) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at org.bukkit.Bukkit.reload(Bukkit.java:525) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:25) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at org.bukkit.craftbukkit.v1_12_R1.CraftServer.dispatchCommand(CraftServer.java:644) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at org.bukkit.craftbukkit.v1_12_R1.CraftServer.dispatchServerCommand(CraftServer.java:630) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at net.minecraft.server.v1_12_R1.DedicatedServer.aP(DedicatedServer.java:443) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at net.minecraft.server.v1_12_R1.DedicatedServer.D(DedicatedServer.java:406) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at net.minecraft.server.v1_12_R1.MinecraftServer.C(MinecraftServer.java:678) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:576) [spigot.jar:git-Spigot-ede465d-bb4ae3b]

    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_112]

    I am grateful for any ideas. Thank you so much. Cheers!
     
  2. Also... did I put this under the wrong forum heading? I don't want to run afoul of norms.
     
  3. You put it under the right forum section, all you need to do is get newer versions, I'm assuming they are out dated and for older versions
     
    • Like Like x 1
  4. That's the part that's confusing me. I *just* pulled those versions posted as the newest from the respective sources, and replaced the .jar files in my plugins directory.
     
  5. Maybe treasure chest reloaded isn't made for your server version, what so your server version?
     
    • Like Like x 1
  6. I'm running 1.12 as of today. It's given me that error since I built the server (1.10). It's always worked just fine, but it spits that error every start. I think it was updated last a year ago, so perhaps it's not the most compatible plugin. If there is another that does the same thing, I'd be happy to check it out. Even so, like I said, it functions. I just wasn't sure if that error was critical in any way.

    The WorldGuard is weird. I DL'ed 6.2 today. I still says it's launching 6.1.3. I don't get it. And that one is definitely behaving poorly. Some regions are being really erratic.