Update?

Discussion in 'Spigot Discussion' started by phospholipid, Jun 20, 2018.

Thread Status:
Not open for further replies.
  1. I'm trying to run a routing update (it's been a while) and when I do, the process lands at this:

    "Rebuilding Forked projects....

    fatal: '/Volumes/Nicodemus/MyFolders/Jaime/Documents/MCTrial/WorldLobby/Bukkit' does not appear to be a git repository

    fatal: Could not read from remote repository."

    Any thoughts? ​
     
  2. electronicboy

    IRC Staff

    Delete the Bukkit folder, (or just delete the entirety of buildtools and rerun it)
     
    • Friendly Friendly x 1
  3. That was a good first guess, but it didn't work. Buildtools made a new Bukkit directory, which is all fine and good, but then the process failed again with the same result and I don't really know what to do with it.

    There is something very bizarre about the error. The portion that I have highlighted in RED is a path that is on another computer entirely!! That path is on my laptop. However, the server is on a desktop in my office, and I am running the Terminal application on that desktop. What is happening? Why is the instance of Buildtools running on Terminal on my desktop trying to use a directory on my laptop?

    The portion in BLUE is a path that is, in fact, on the desktop. Any thoughts about what is going on?

    ++++++++++++++++++++++++++++++++++++++

    Rebuilding Forked projects....

    fatal: '/Volumes/Nicodemus/MyFolders/Jaime/Documents/MCTrial/WorldLobby/Bukkit' does not appear to be a git repository

    fatal: Could not read from remote repository.


    Please make sure you have the correct access rights

    and the repository exists.

    HEAD is now at dcc4266 SPIGOT-3604: Deprecate unused professions

    Resetting Spigot-API to Bukkit...

    HEAD is now at dcc4266 SPIGOT-3604: Deprecate unused professions

    Applying patches to Spigot-API...

    Applying: POM Changes

    fatal: sha1 information is lacking or useless (pom.xml).

    Repository lacks necessary blobs to fall back on 3-way merge.

    Cannot fall back to three-way merge.

    Patch failed at 0001 POM Changes

    The copy of the patch that failed is found in:

    /Users/admin/Documents/MCTrial/WorldLobby/Spigot/Spigot-API/.git/rebase-apply/patch

    When you have resolved this problem, run "git am --continue".

    If you prefer to skip this patch, run "git am --skip" instead.

    To restore the original branch and stop patching, run "git am --abort".

    Something did not apply cleanly to Spigot-API.

    Please review above details and finish the apply then

    save the changes with rebuildPatches.sh

    Error compiling Spigot. Please check the wiki for FAQs.

    If this does not resolve your issue then please pastebin the entire BuildTools.log.txt file when seeking support.

    java.lang.RuntimeException: Error running command, return status !=0: [sh, applyPatches.sh]

    at org.spigotmc.builder.Builder.runProcess0(Builder.java:639)

    at org.spigotmc.builder.Builder.runProcess(Builder.java:597)

    at org.spigotmc.builder.Builder.main(Builder.java:478)

    at org.spigotmc.builder.Bootstrap.main(Bootstrap.java:29)

    theopolis:WorldLobby admin$
     
  4. Is it important that I originally built this server on my laptop where I tested it, then I copied it over to the desktop (where it's been running for over a year)?
     
    #4 phospholipid, Jun 20, 2018
    Last edited: Jun 20, 2018
  5. I apologize. I absentmindedly posted this thread in the WRONG forum. This post is specifically about server management. Can an admin please move this to the Server and Community management forum?
     
Thread Status:
Not open for further replies.