Updated to 1.9.4, can't connect [Outdated server]

Discussion in 'Spigot Help' started by robwir0106, May 10, 2016.

  1. Hello,

    I recently updated to Craftbukkit 1.9.4 with the latest BuildTools. I run the following "java -jar BuildTools.jar --rev 1.9.4" command to get the latest jars and then copied the files to my server. But when I'm trying to connect to my server I get the following message
    - Outdated server! I'm still on CraftBukkit1.9.2

    But the logs from my server says somethins else :confused:
    [22:10:07] [Server thread/INFO]: Starting minecraft server version 1.9.4
    [22:10:07] [Server thread/INFO]: Loading properties
    [22:10:07] [Server thread/INFO]: Default game type: SURVIVAL
    [22:10:07] [Server thread/INFO]: Generating keypair
    [22:10:07] [Server thread/INFO]: Starting Minecraft server on 192.168.1.3:25567
    [22:10:07] [Server thread/INFO]: Using default channel type
    [22:10:07] [Server thread/INFO]: This server is running CraftBukkit version git-Bukkit-c5e9a16 (MC: 1.9.4) (Implementing API version 1.9.4-R0.1-SNAPSHOT)

    What can be wrong?
     
  2. Are you on 1.9.4?
     
  3. Yes, i'm on 1.9.4
     
  4. K, then IDK why :(
     
  5. Did you actually copy the new server jar into your server?
     
  6. Yes, both with MineOS GUI and manually with cp command from terminal

    Edit: Check log at the first post
     
  7. What do you get with /version?
     
  8. can't run that command o_O
     
  9. [22:10:07] [Server thread/INFO]: This server is running CraftBukkit version git-Bukkit-c5e9a16 (MC: 1.9.4) (Implementing API version 1.9.4-R0.1-SNAPSHOT

    Is it the wrong API version/snapshot?
     
    #10 robwir0106, May 11, 2016
    Last edited: May 11, 2016
    • Informative Informative x 1
  10. Finally I got it to work! :)
    I made the following steps
    - Restarted the server from MineOS webui - didn't helped
    - Compilied it several times and copied the jar manually thru terminal - didn't helped
    - Restarted the plugin and jail in FreeNAS, same as restarting the server - didn't either fixed it
    - Restarted the whole FreeNAS instance - WORKED!!!

    Many thanks for the help!
     
  11. No problem :) Glad you got it working :)
     
  12. I'm feeling very dumd right now :oops:
    I have for some reason changed to the 1.9.2 version on the Minecraft client and when I changed it back to the latest (1.9.4) the same problem as earlier was back in my face again.....:mad:

    So the problem still remains, any suggestions? o_O
     
  13. :D you have ofcourse restarted everything this time?