Solved Updating server to 1.17.1?

Discussion in 'Spigot Help' started by Whatamianoob, Jul 9, 2021.

  1. Greetings friends.
    I'm trying to upgrade the family Minecraft server from some 1.16 (or maybe even earlier) version to 1.17.1.

    The server upgraded to 1.17 but for the life of me I cannot get it to 1.17.1

    I tried running the BuildTools script:
    Code (Text):
    java -jar BuildTools.jar --rev 1.17.1
    That went through the process of building the chunks and everything, but the server version is not changing.

    For reference, I set the server up to be a service managed by systemctl on ubuntu mint, if that matters.
    Am I missing something?

    The start script I am using is as follows:
    Code (Text):
    #!/bin/sh
    cd /home/kirby/Documents/Minecraft_current &&
    java -Xmx4G -Xms1G -jar server.jar spigot-1.17.1.jar --forceUpgrade nogui
    Any thoughts?
     
    #1 Whatamianoob, Jul 9, 2021
    Last edited: Jul 9, 2021
  2. Screenshot 2021-07-10 at 00.19.35.png

    this gives you the spigot file, it doesn't do anything to chunks or running the server
     
  3. Screenshot 2021-07-10 at 00.20.19.png
    why are you trying to start the jvm with 2 server jars?

    forceupgrade is only needed "once"
     
  4. You handsome handsome man, good point.

    The issue was that it was loading the (outdated) server.jar.

    Why did I think I needed both? Solved.