Upgrading Spigot Server

Discussion in 'Spigot Help' started by GMI3, Feb 25, 2020.

  1. I am trying to update my spigot server to a newer version of minecraft but in the thread about the update its telling me to do --forceUpgrade and I have no idea where to put that. Any help would be greatly appreciated!
     
  2. After the spigot.jar part e.g.

    Code (Text):
    java -jar spigot.jar --forceUpgrade
     
    • Winner Winner x 1
  3. Before doing this, ensure that your plugins all support 1.14, otherwise your server will end up exploding once you start the server after upgrading because the plugins one by one don't work. And because they aren't supported by 1.14, they don't load when running. Which will make you lose your progress.
     
  4. step 1
    100% backup, this includes the files and any mysql databases, etc.
     
    • Agree Agree x 2