Spigot uSkyBlock v2.7.6-RC3

The best Skyblock out there...

  1. unfortunately there is no BOOK_AND_QUILL in any .yml, but thanks
     
  2. Well, the exception says there is. Do you have multiple versions of uSkyBlock.jar in your plugins folder?
    Or have you tried one of the latest pre-releases?
     
  3. just checked it again on the testserver with the latest version of uSkyblock, same error:

    [11:34:16 INFO]: Name: uSkyBlock
    [11:34:16 INFO]: Version: 2.7.6-201809011049
    [11:34:16 INFO]: Description: Ultimate SkyBlock v2.7.6-201809011049-0525c4
    [11:34:16 INFO]: Language: en (en)
    [11:34:16 INFO]: State: d=128, r=64, i=2, p=2, n=true, awe=false
    [11:34:16 INFO]: Server: CraftBukkit git-Spigot-2440e18-dc69d2b (MC: 1.13.1)
    [11:34:16 INFO]: State: online=true, bungee=false
    [11:34:16 INFO]: ------------------------------
    [11:34:16 INFO]: Vault 1.6.7-b${env.TRAVIS_BUILD_NUMBER} (ENABLED)
    [11:34:16 INFO]: WorldEdit 7.0.0-SNAPSHOT;3859-8bfbc55 (ENABLED)
    [11:34:16 INFO]: WorldGuard 7.0.0-SNAPSHOT;1743-8771173 (ENABLED)
    [11:34:16 INFO]: Multiverse-Core 2.6.0-b738 (ENABLED)
    [11:34:16 INFO]: Multiverse-NetherPortals 2.5.2-SNAPSHOT-b729 (ENABLED)
    [11:34:16 INFO]: ------------------------------

    i just saw there ist also a error with: CommandException: Unhandled exception executing command 'c' in plugin uSkyBlock v2.7.6-201809011049

    but i have no idea what that mean.

    https://pastebin.com/XaBPDy5q
     
  4. Well, if you (just for test), delete everything in the plugins/uSkyBlock folder, and make sure you have the latest .jar file (and no other/older uSkyBlock.jar files around), do you still get the same error?
     
  5. i deleted both worlds, uSkyblock Config folder, kopied in the latest uSkyBlock.jar ...started the server and tried to klick Challenges:

    the complete serverlog, i hope it helps:
    https://pastebin.com/aB5gWgpn

    /usb version output:
    https://pastebin.com/ed19v31G

    /pl Output:
    https://pastebin.com/C6ktt0Zy
     
  6. When do you make update for version 1.13.1?
     
  7. new dev version available on github and it works fine with spigot 1.13.1
     
  8. Hey, my players are having an issue where they can't plant a sapling on certain grass blocks on their island.

    It's not throwing them a reason, and it's not throwing a console error.

    Has anyone had the same issue? I tried to google the problem with no luck.

    Edit: I fixed my issue by disabling GriefPrevention on the SkyBlock worlds.
     
    #2671 PrestigiousAZ, Sep 13, 2018
    Last edited: Sep 13, 2018
  9. Hi everybody! I'm having a issue I'm running spigot 1.13 got the new uskyblock plugin and it does install but when I make an island after its done it says UNSAFE I even went to the location of where the island is and there is nothing there????




    java.lang.NullPointerException: null at com.google.common.base.Preconditions.checkNotNull(Preconditions.java:770) ~[spigot-1.13.jar:git-Spigot-fe3ab0d-162bda9] at com.sk89q.worldedit.extent.clipboard.io.ClipboardFormats.findByFile(ClipboardFormats.java:92) ~[?:?] at us.talabrek.ultimateskyblock.handler.WorldEditHandler.loadIslandSchematic(WorldEditHandler.java:58) ~[?:?] at us.talabrek.ultimateskyblock.handler.AsyncWorldEditHandler$1.loadIslandSchematic(AsyncWorldEditHandler.java:119) ~[?:?] at us.talabrek.ultimateskyblock.handler.task.WEPasteSchematic.run(WEPasteSchematic.java:26) ~[?:?] at org.bukkit.craftbukkit.v1_13_R1.scheduler.CraftTask.run(CraftTask.java:76) ~[spigot-1.13.jar:git-Spigot-fe3ab0d-162bda9] at org.bukkit.craftbukkit.v1_13_R1.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:361) [spigot-1.13.jar:git-Spigot-fe3ab0d-162bda9] at net.minecraft.server.v1_13_R1.MinecraftServer.w(MinecraftServer.java:877) [spigot-1.13.jar:git-Spigot-fe3ab0d-162bda9] at net.minecraft.server.v1_13_R1.DedicatedServer.w(DedicatedServer.java:411) [spigot-1.13.jar:git-Spigot-fe3ab0d-162bda9] at net.minecraft.server.v1_13_R1.MinecraftServer.v(MinecraftServer.java:819) [spigot-1.13.jar:git-Spigot-fe3ab0d-162bda9] at net.minecraft.server.v1_13_R1.MinecraftServer.run(MinecraftServer.java:717) [spigot-1.13.jar:git-Spigot-fe3ab0d-162bda9] at java.lang.Thread.run(Thread.java:748) [?:1.8.0_172] [13:08:22 INFO]: [WorldGuard] Region data changes made in 'skyworld_nether' have been background saved [13:08:22 INFO]: [WorldGuard] Region data changes made in 'skyworld' have been background saved [13:08:29 ERROR]: [uSkyBlock] Could not find a safe chest within 15 blocks of the island spawn. Bad schematic! [13:08:40 INFO]: djbleachburn issued server command: /is [13:08:52 INFO]: [WorldGuard] Region data changes made in 'skyworld_nether' have been background saved [13:08:52 INFO]: [WorldGuard] Region data changes made in 'skyworld' have been background saved


    Thats the error I get too.
     
    #2673 djbleachburn, Sep 14, 2018
    Last edited: Sep 16, 2018
  10. Please provide the output from /usb version.

    It seems the version of WorldEdit you are using isn't compatible with the version of uSkyBlock.
     
  11. Hey @R4zorax. I posted a bit of a issues with uSkyblock. I posted it on Github.
     
  12. Hello. Is there a way to convert our 1.12 ASkyblock plugin information and database (such as player islands, challenges completed, parties, etc) to your 1.13 uSkyblock plugin?

    Thank you.
     
  13. Okay im in need of some help

    I started out createing a server
    ive waited a while after the server have created all the worlds
    i then login move my self over to the skyworld by useing Multivers
    Next of i build a Nether portal Nothing happends when i go in it....
    shut down the server then found Multiverse-NetherPortals-2.5
    restart the server im then teleported to nether but now the weird part 1 time i had half an island and the bottom was a bunch of holes with lave an bedrock Redid the whole server again and login again this time my portal ended up in the top of the nether there where some nether rack that was all

    redid it again hopeing i was more lucky this time
    This time the nether had only created the portal with 2 obsidian in each end so i would fall

    What is going on here is This plugin bugged or nothing works becaus of 1.13 ?
    All the above was done in 1.13

    Tried going to 1.13.1
    Seems its even whorse The server dosent even create a Nether it stop after it has created Skyworld then it just stops and waiting for you to logon or what ever but still no Skyworld_Nether
    what is going on ?

    Redid it again can any one confirm that this is how the nether should look ?
    https://imgur.com/a/IFx2kHn
     
    #2677 Zaris24, Sep 24, 2018
    Last edited: Sep 24, 2018
  14. You have two options with uskyblock, you can let the plugin create a nether island like you did, some players prefer this.

    Or you can create your own nether world before the plugin creates it.

    To do that, you need to delete skyworld_nether (/mv delte skyworld_nether)
    then create the world again using (/mv create skyworld_nether nether)
     
  15. I tried this But when i finaly got in to the nether the only thing that was made inside it was the nether portal in the middel of nothing
    i mean there should be an island right? There used to be in 1.12 how come theres nearly nothing in the nether now :p

    also can you maybe confirm that the picture i added above is how the nether should look or is it one more of the weird bugs i have gotten
     
  16. Help! Please!
    i use spigot 1.13
    and newest worldguard and worledit and when
    i type /island or /is, nothing happens
    plz plz plz plz