UTF Special Characters

Discussion in 'Server & Community Management' started by Cmoor, Jul 7, 2015.

  1. Hello Spigot Community!
    So I am having a bit of an issue. I have ranks that use special characters(makes them look a bit nicer) Now on my hub server they work. but on the Towny server they do not. I have tried saving the Essentials config in UTF-8 and no change. I do have EssentialsChat as well to be sure but with or without it, it doesn't change. I believe Essentials is stopping me from doing this but if there is a solution it would be more than appreciated if someone would tell me how.

    Towny:
    Plugins (19): AsyncWorldEditInjector, CoreProtect, WorldEdit, AsyncWorldEdit, Questioner, Essentials, EssentialsProtect, EssentialsChat, EssentialsAntiBuild, PermissionsEx, mcMMO, Lockette, Vault, EssentialsSpawn, WorldGuard, OnTime, Towny, Jobs, DeluxeChat

    Hub:
    Plugins (11): AsyncWorldEditInjector, WorldEdit, AsyncWorldEdit, PermissionsEx, WorldGuard, SkyArchGun, HubBasics, MicroJump, AdvancedSelector, NoFlyZone, BungeePortals

    [​IMG]
     
  2. Update your spigot.
     
  3. Well currently I'm using 1.8.6. So I need to use 1.8.7?
     
  4. yes ☻

    lol i was using alt and then 2 :p
     
  5. Nope, i updated to spigot 1.8.7 and still no change. also my hub and towny are using the same spigot versions and as i said before, hub server allows UTF characters but towny server does not.
     
  6. Escape them to \uXXXX format.
     
  7. yeah i tried that and it just gives smiley faces...was kind of funny when it happened xD
     
  8. if this helps, i tried to do \u2020 which is '†' which is the unicode dagger. but that is only one of the few UTF characters I have used.
     
  9. okay i fixed it! All i had to do was go to Encoding tab (Notepad++) and instead of choosing UTF-8 without BOM, i hit convert to ANSI. For some reason that worked xD Just in case others were having this issue as well =]
     
  10. I converted it to ANSI and it reset my whole Essentials config file. .-. Do you know how long it took me to make that? -.-
     
  11. erm sorry haha i understand though, i did it like 3 times until i finally got it. don't know why it got all messed up for you though?
     
  12. That sucks. I'm trying to get my server host to get the file back. I'm pretty sure he can get it back. If not, I'll have to make it all over again. :/
     
  13. its only essentials. ive redone my essentials config countless times. you don't have a backup? like on your pc?