Solved Vault not loading up cause it thinks it is already loaded....

Discussion in 'Spigot Plugin Help' started by kinggoesgaming, May 8, 2015.

  1. Hi guys i have a major problem with vault going on. When the server runs it prints the following in the console

    http://pastebin.com/u4iFfHxt

    I ran server before with same spigot version and vault version before and didnt have an issue so really cant figure what went wrong. And since vault is a dependency for so many plugins my server is basically stalled :(

    Any help would be appreciated :D

    Vault Version: 1.5.3
    Spigot version: git-Spigot-2ec6f06-7722428 (MC: 1.8.3) (Implementing API version 1.8.3-R0.1-SNAPSHOT)
     
    #1 kinggoesgaming, May 8, 2015
    Last edited: May 8, 2015
  2. Bump

    i really need this running.
     
  3. Generally, this error will happen if 2 plugins have the link to the same Main class. So, I assume you already have Vault installed and don't know it, maybe another version w/a different file name?
     
  4. This only occurs if you have Vault in your server 2 times. When Vault updates it changes the name to the version, so check your server files and delete the old version of the plugin.
     
  5. ok i have these plugins:
    • AutoMessage
    • AutoRestart
    • boosCooldowns
    • BuildingTools
    • ChestCommands
    • Citizens
    • Clearlag
    • ColoredAnvils
    • CoreProtect
    • DeluxeJoin
    • DeluxeTags
    • Denizens
    • EditableSign
    • Essentials
    • EssentialsChat
    • Furniture
    • GiantTrees
    • Grief Prevention Real Estate
    • Grief Prevention
    • HolographicDisplays
    • HostHordeHealth
    • Jobs
    • JustOneMore
    • KitAdder
    • LibsDisguises
    • MazeGenerator
    • mcMMO
    • MultiverseCore
    • MultiversePortals
    • NoCheatPlus
    • OpenInv
    • Parkour
    • PermissionsShop
    • PlaceholderAPI
    • PlayerTutorials
    • PlayerVaults
    • PlugMan
    • PrimeShop
    • ProtocolLib
    • RandomLocation
    • SuperVanish
    • SeparateWorldInventories
    • TitleManager
    • TouchScreenHolograms
    • vAliasFilter
    • Vault
    • WorldEdit
    • WorldGuard

    None of these are double inserted ( 52 plugins and 52 jarfiles). Just cant seem to find the problem :/
     
  6. Well, i'd recommend uninstalling all plugins excluding Vault (test if it's enabled) and Essentials (so Vault has an economy to use), and re-enable each plugin one by one to catch which one is causing the Vault problem.
     
  7. Remove all your plugins, test it. If it don't work. I don't can help you.
     
  8. I had to set a server for my brother's civilization hw so didnt get time to that. I will get some time soon i think thats a good shoutout
     
  9. ok i got it running on a separate server( everything is same as before)

    I dont know what happened what hopefully it keeps running and doesnt break :D